Paste a table as plain-text? (InDesign)

Discussion in 'Design and Graphics' started by DaSal, Mar 20, 2008.

  1. macrumors regular

    Joined:
    Mar 19, 2008
    Location:
    The Netherlands
    #1
    I can't seem to figure out how to paste a table from a program like Word, Pages or Excel, hell, seems to be any program, as plain text. Whenever I select the table and copy it it'll just paste it into InDesign, or Photoshop, whichever other app, as a (low quality) picture. This is very very inconviently as I regularly need to copy tables as plain text into InDesign. Can someone please tell me how to do this?

    Thanks in advance!;)
     
  2. macrumors 65816

    design-is

    Joined:
    Oct 17, 2007
    Location:
    London / U.K.
    #2
    I'm not saying I can, or this will, help - but what versions of word/office & Adobe software are you using?

    May be useful.
     
  3. thread starter macrumors regular

    Joined:
    Mar 19, 2008
    Location:
    The Netherlands
    #3
    Sorry, latest versions of iWork/Office and CS3 Adobe products.
     
  4. macrumors 68040

    Sdashiki

    Joined:
    Aug 11, 2005
    Location:
    Behind the lens
    #4
    Ive tried and tried to do something like this, it just doesnt work for me.

    Everyone has Office, only I have Adobe. So all the information for my Adobe products comes from Office products. Lots of copy and pasting and formatting.


    Anyone who has a solution would be revered.
     
  5. thread starter macrumors regular

    Joined:
    Mar 19, 2008
    Location:
    The Netherlands
    #5
    I know it does it as plain text by default on Windows. It's really annoying cause right now I have to switch to windows to do some things, it's real time hog. Really hope someone has a solution.
     
  6. macrumors 65816

    design-is

    Joined:
    Oct 17, 2007
    Location:
    London / U.K.
    #6
    I've not got access to hand, but will play over the Easter break and get back to you if no one has helped already :)
     
  7. macrumors member

    flrazor

    Joined:
    Jun 29, 2004
    Location:
    Saint Paul, MN
    #7
    Try the Place command

    This might be a simple fix to what you're doing (I know this works for Excel spreadsheets since I've had to do this a lot at work), give this a try:

    Use the Place (cmd + D) dialogue and select your Excel or Word document. Make sure to have the Show Import Options toggle checked. The resulting window will ask you what sheets and what cell ranges you want to use, as well as options for what kind of table (formatted/unformatted) you'd like. You can always edit out stuff you don't need later if you don't know your ranges and that stuff. Once you get all your options, it places similar to an image, but it's editable text and cells you can change and format however you want. just have to play with your table options to get it where you want it.

    I saw this at a seminar when CS came out and it blew my mind, so I hope that this does what you want it to do and gets you moving in the right direction. I have not tried this with tables that are in Word docs, but I know you can import text from a Word document this way very similarly with the Place command. No experience with trying to do the same from iWork, but if most of your stuff is coming in from Excel/Word, then that should work fine. See how that works out for you. :)
     
  8. macrumors member

    Joined:
    Jun 28, 2007
    #8
    Strange, It seems to work for me. I copy the contents of the table (works in word & excel) and when I paste it into Indesign it pastes in as text, with a tab in between "columns" which I can then change back into a table by going to "table"-->"convert text to table".

    Or if I change my indesign clipboard settings (see attachment), I can paste in a table and preserve any styles/text/sizes that I have already applied in word (row spacing seems to go a bit wonky, but it's a start).
     

    Attached Files:

  9. thread starter macrumors regular

    Joined:
    Mar 19, 2008
    Location:
    The Netherlands
    #9
    Won't work for me :( Had to work with tables again today, had to boot into windows again, I really hope somebody has a solution.. :(
     
  10. macrumors newbie

    Joined:
    Nov 1, 2004
    #10
    Old thread - which I found while trying to find a solution to the same problem.

    Solution is to draw a text frame and paste the text or table from Excel into that, instead of just pasting straight onto the page. Doing the first way means that editable text is imported.

    And you can adjust the Clipboard Handling preferences to set whether you want the text pasted plain or as a table.
     

Share This Page