PB G4 only charges when off or when asleep

Discussion in 'PowerPC Macs' started by Mpowerbook182, Mar 20, 2006.

  1. macrumors newbie

    Joined:
    Nov 17, 2004
    #1
    Hello I haven't posted in along time. Recently though my powerbook will only charge its battery when it's turned off or in sleep mode. I have tried resetting the pram and my pb does not fall into the battery firmware update. Any help would be great.

    Thanks
     
  2. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Try resetting your PMU and then maybe calibrate your battery, just for fun.

    Calibrating a battery involves running the machine from battery until it falls asleep through lack of power, and then charging it up to 100%. :)
     
  3. macrumors 68000

    calebjohnston

    Joined:
    Jan 24, 2006
    #3
    I had this problem with my iBook for a few days, but it seemingly fixed itself - haven't had the problem for 2 weeks or so. Are you updated to 10.4.5 with the security updates? I doubt those made a difference, but ya never knooooooooooooooooooooooooow.

    Either way, it could just be a matter of time for you. Or madjew could be right. Or both.

    I'm real hungry.
     
  4. thread starter macrumors newbie

    Joined:
    Nov 17, 2004
    #4
    I have tried these both but it didn't fix it. My computer has now been at 3% for some time (pluged in), since i have needed to use it all day, i will let it charge later when i can put into sleep mode. Thanks for the ideas sofar, hopefully i don't have to take it in. I think i still have a few months of applecare, but last time i had a problem it was a pain, they tried to fix it 3 times and finally ended up giving me a new pb. thanks again.
     
  5. thread starter macrumors newbie

    Joined:
    Nov 17, 2004
    #5
    Update, I let it charge in sleep mode and when it was finally charged the ring did not turn green it just turned off, even in sleep mode.
     
  6. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #6
    Do you have another charger or another battery you can use to see where the problem lies? Either way, I think this is probably a job for Apple. Just tell them the steps you've taken to fix it and they hopefully won't mess you around too much. :)
     
  7. macrumors regular

    Joined:
    Oct 28, 2001
    #7
    that is strange, I just started having this problem exactly, today. I'm quite worried!
     
  8. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #8
    What steps have you taken? :)
     
  9. macrumors regular

    Joined:
    Oct 28, 2001
    #9
    I zapped the PRAM and I'm going to reset the PMU, but I'm sort of afraid that won't work...
     
  10. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #10
    After that, maybe try re-seating the battery (take it out and put it back in again). It also probably won't work, but it's worth a shot. :)
     

Share This Page