PB keyboard problem, or just me?

Discussion in 'Macintosh Computers' started by zelmo, Feb 21, 2005.

  1. macrumors 603

    zelmo

    Joined:
    Jul 3, 2004
    Location:
    Mac since 7.5
    #1
    When I type on my PB, I frequently encounter a problem that I thought was just me: As I type, I will look up at the screen and see that I am suddenly now typing in the middle of what I have previously typed, as if I inadvertently moved the cursor and inserted it in the body of the copy I am writing. This only happens when I am using my PB.

    Initially, I figured that I must be accidentally hitting the trackpad while typing, even though I take extra care not to. I checked my preferences, and have the trackpad set to ignore accidental trackpad input while typing, but this does not appear to be working.
    Today, I was talking with a co-worker who recently bought a PB, and I asked him if I could type a bit on his keypad. When he asked me why and I started to explain, he started nodding, and asserted that he had the same problem. I have the rev C 1.33 15" (no backlight), and he has the rev C 1.5 15" w/backlit keys. Neither being trained typists, we are both using the hunt-and-peck method.

    A: Is there some setting we are both overlooking?
    B: Are we both mysteriously doing the exact same thing when typing, despite our efforts to avoid contact with the trackpad?
    C: Is this a common problem with PB's (or laptops in general)?
    D: Is there something wrong with both these Powerbooks?
     
  2. macrumors 68000

    Joined:
    May 10, 2004
    Location:
    Nottingham
    #2
    I do it occasionally, too, though less with practice.

    Put it down to hitting the trackpad, perhaps dust on the 'pad... can't really see it being anything else...
     
  3. macrumors 68000

    atari1356

    Joined:
    Feb 27, 2004
    #3
    Yeah, it's definitely the trackpad... I've done it on occassion, I just try to keep my wrists/thumbs raised up away from the trackpad.

    Although I wonder sometimes if it could be static electricity, when it seems like you weren't that close to the trackpad and it still happens.
     
  4. Administrator

    annk

    Staff Member

    Joined:
    Apr 18, 2004
    Location:
    Somewhere over the rainbow
    #4
    Same thing happens to me, but not only on my PB - also on Windows laptops. A bluetooth mouse solved the problem....But it's a shame not to be able to use the trackpad without that happening. Too bad the "ignore accidental..." doesn't work.
     
  5. macrumors 6502a

    Joined:
    Mar 19, 2002
    Location:
    Atlanta, GA
    #5
    By any chance do you have Sidetrack installed?

    I do and have noticed that even though I have "Ignore trackpad while typing" set in Sidetrack it still does it.

    Before I had Sidetrack installed it used to work (as in 'not' work when I was typing) fine.

    Vanilla
     
  6. macrumors 6502a

    Joined:
    May 17, 2004
    Location:
    NYC
    #6
    This happens to me sometimes on my Dell and on my Pismo. Less often on the Pismo, because I hardly use it.

    I am fairly certain that it is due to the placement of the trackpad.
     
  7. macrumors member

    Joined:
    Apr 26, 2003
    #7
    not alone

    You're not alone. My wife has an iBook and me a Powerbook, and this doesn't ever happen to me. It doesn't happen if she's typing on her iBook, but it does if she uses my PB. Must be where they put the trackpad...but odd that it still happens to you even though you're hunting and pecking.
     
  8. macrumors 68020

    Joined:
    Jan 23, 2005
    #8
    Happens on my dads dell laptop.

    I think it is because when you type, your hands are inadvertantly touching the bottom of the keyboard, next to the mouse pad thingy (dont know what dell calls 'em, trackpads also??) and it puts pressure on it.

    If you plug a mouse into the dell, the trackpad stops.
     
  9. Administrator

    annk

    Staff Member

    Joined:
    Apr 18, 2004
    Location:
    Somewhere over the rainbow
    #9
    I do have Sidetrack installed, but I seem to remember the problem was there before, too.
     
  10. thread starter macrumors 603

    zelmo

    Joined:
    Jul 3, 2004
    Location:
    Mac since 7.5
    #10
    I had the Sidetrack as freeware, but it is disabled since I didn't pony up the cash. I'll uninstall.
    Can't honestly say that this problem started when I installed Sidetrack, but I think it pre-dates that event.
    I hardly ever use a BT mouse, but I'll try that and see if having one in (and disabling the trackpad) does the trick for sure.

    Thanks to all for ideas, and for confirming that it probably isn't just me ;)
     
  11. macrumors regular

    Joined:
    Sep 10, 2004
    Location:
    Boston
    #11
    I've never had this happen to me. I have "use the trackpad for: clicking" turned off, do you all have it on? That must be it.
     
  12. Administrator

    annk

    Staff Member

    Joined:
    Apr 18, 2004
    Location:
    Somewhere over the rainbow
    #12
    I've got it turned off, too - so it must be some mysterious thing about how we as individuals type :eek:
     
  13. macrumors regular

    Joined:
    Sep 10, 2004
    Location:
    Boston
    #13
    Does that mean you are hitting the trackpad button too? With the trakpad for clicking off, even if you just brush the pad it should not move the cursor. I find it hard to believe that you are hitting thebutton with out noticing it. We need to get to the buttom of this.
     
  14. Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #14
    This happened to me initially, for the first four or five months after I got my iBook 12", but I don't notice it much anymore. I figured it was the trackpad too, but I never really figured it out. I definitely had the problem before Sidetrack, and I'm pretty sure I did have accidental trackpad ignore set on. I did have trackpad tap turned on, though. Having this happen with that turned off is just strange. And I can't explain why I don't really have the issue anymore. Creepy. ;)
     
  15. macrumors regular

    Joined:
    Dec 10, 2004
    Location:
    Nashville, TN
    #15
    I have this problem off and on on my iBook G4 too. I try and take care to keep my wrists up so that they are nowhere near the trackpad but the cursor does jump to the middle of previous typed text for no apparent reason. I have the accindental trackpad ignore thing set ON and I have trackpad tapping set to ON. Verr weird.. But I use my laptop mostly on soft cushiony sorface like the couch or bed so maybe that might cause a slight bounce which may freak out the trackpad :confused: :confused:
     
  16. macrumors 6502a

    Joined:
    Mar 19, 2002
    Location:
    Atlanta, GA
    #16
    Well I've just removed SideTrack and clicked the "Ignore accidental trackpad input" in the Trackpad area of the Keyboard & Mouse section of System preferences and I no longer have the random jumping cursor issue, so to my mind its pretty conclusive that Sidetrack is the culprit.
    Vanilla
     
  17. Administrator

    annk

    Staff Member

    Joined:
    Apr 18, 2004
    Location:
    Somewhere over the rainbow
    #17
    If it's true it's Sidetrack, that's a real bummer. I love being able to scroll using my trackpad.
     
  18. macrumors 6502a

    Joined:
    Mar 19, 2002
    Location:
    Atlanta, GA
    #18
    Just an addendum, its important to COMPLETELY remove Sidtrack, which is done by using the uninstall option in the installer function.

    No guarantees, but it resolved the "independent free-spirit" cursor problem for me.
    cheers
    Vanilla
     
  19. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #19
    Have you got INCREDIBLY hairy arms? It sounds like a joke but a friend of mine with far too much testosterone for his own good can barely type his name on my iBook... :D Quite funny to watch really! :p
     
  20. macrumors newbie

    Joined:
    Jun 2, 2004
    #20
    Just to clarify, this isn't a problem with the current version of SideTrack. The problem Vanilla was facing is that he probably didn't uninstall SideTrack completely. When the SideTrack driver is still loaded the Apple option switch for "Ignore while typing" doesn't have any effect, SideTrack's looking for its own preference instead.

    Vanilla also doesn't mention how old the version of SideTrack he had installed, but I'm betting its old. All current versions of the SideTrack driver have a sanity check at load that make sure to warn the user if they've attempted to delete SideTrack without actually removing the driver.

    Alex
    (SideTrack's author)
     

Share This Page