PC not showing up in Finder

Discussion in 'Mac OS X Server, Xserve, and Networking' started by SLR2009, Aug 24, 2009.

  1. macrumors regular

    Joined:
    Mar 19, 2009
    #1
    Hi, my Windows Vista computer is not showing up in finder under Shared. I can connect to my PC from my mac by clicking on finder, go, connect to server and typing in the PC's IP Address, Username and Password. I can also see my Mac computer from my PC running Windows Vista.

    What's weird is that it was showing up for awhile but I recently changed my network key and unchecked file sharing on both my Mac and PC.

    Afterwards I re-enabled file sharing on both my mac and Vista computer but since then my PC won't show up in finder.

    I can connect to my PC and see the computer in finder but when I click eject, it disappears. I would like it to remain in finder. Is there some setting that I need to enable? Please help
     
  2. macrumors member

    wad11656

    Joined:
    Feb 20, 2009
    #2
    Hey!

    I'm having a VERY similar problem.

    You see,
    I've been searching ALL DAY & NIGHT today and ALL NIGHT yesterday to share files between my mac and vista. I finally got my Vista to access my Mac by making Vista think my Mac was a hard drive, but in my Mac, I only get this:

    [​IMG]

    When I click "Connect As...," usually with other shared devices, it pops up a window for username and password, but this time it didn't.

    Some important things to note are that I've already gone to the security options and changed the policy to"NTLMV2 session security if negotiated" on the Vista

    And...

    The single account on my Vista PC has no password. I've been hearing in other forums that having a password is vital in order for a Mac to connect to a Vista PC.

    Please help us!!! Thank you!

    ----

    Mac OS X 10.5.8

    Windows Vista Business Edition

    ----

    Another thing.

    I've been hearing that a solution directly stated from Microsoft is to download Samba 3 if you have Samba 2 in order to succesfully connect to a Mac.
    HOW do I check which version of Samba I have? Also, when I tried to download Samba 3, there were very confusing Linux/Unix code instructions, and as an almost foreigner to such things, I had no idea where to start. Thank you!
     
  3. macrumors member

    Joined:
    Jul 29, 2009
    #3
    I have exact the same problem, can somebody help us :)
     
  4. macrumors member

    wad11656

    Joined:
    Feb 20, 2009
    #4
    Please, please, PLEASE help us! I know there must be a simple solution out there. Please enlighten us! :D

    Our question is getting drowned out by all the Snow Leopard server questions D:

    Thank you :)
     
  5. macrumors member

    Joined:
    Sep 27, 2008
    #5
    I too am unable to see any of my windows PCs in finder under the shared tab. I am able to connect to everything via the connect to server option and then manually typing in smb://192.168.1.x Under tiger I was able to see the PCs just fine, however after the switch to 10.5 and then 10.6 I have since not been able to see them. I have two Vista desktops, 2 windows 7 laptops, a MS Server 2008 box and a Ubuntu server 9.04 box. All are shared, and can see each other just fine, however the mac is the only machine that can't see the rest without me manually pointing it.

    Below is my network diagram

    Linksys WRT310n Running DD-WRT v24 SP2
    -DHCP
    -DNS

    GLADOS (Domain server)
    -WINS
    -Printer Server

    The PCs can all see each other, as well as my mac (they can even connect to the Mac's dropbox folder and upload/download), and when other Macs are in the house my Mac can see them. It is quite frustrating, and I want to believe it is a DNS or workgroup issue on the mac, however can't figure it out.

    Also I have manually typed in the SMB workgroup in my network preferences, still no luck.

    Cheers
    Cameron
     
  6. thread starter macrumors regular

    Joined:
    Mar 19, 2009
    #6
    My PC is showing up again under finder. Restarting my PC a couple of times seemed to cause my PC to show up in Finder under shared. I'm not exactly what I did to get it to show up but restarting the computer a couple times seemed to be the answer.

    wad11656 and Nickm4N: you need to give your account on your PC a password. You can only connect to your PC from your Mac if you have a password.

    Go on your mac, click on finder, go, type this in SMB://Account name:password@ipaddress/

    The account name will be the account that you have shared on your PC, type the password of that account, enter the ip address of your PC.

    If you still have trouble connecting then try creating a new account on your PC. Select the folder that you want to share and type in the name of your new account, hit enter.

    Then go on your mac, click on finder, go and type in the address that I mentioned before except this time enter the new account that you created on your PC, the password of that account, and the IP address of your PC.


    Hope that helps.
     
  7. thread starter macrumors regular

    Joined:
    Mar 19, 2009
    #7
    Looks like I spoke too soon. I restarted my Mac and now my PC is not showing up in finder again :(. I hope this issue is fixed with Snow Leopard. Anyone know if it is?
     
  8. macrumors member

    Joined:
    Sep 27, 2008
    #8
    Nope, I was hoping that too, however they don't show up.

    Are you at least able to connect to your PCs via SMB? I know that I can connect to any network resource I want (PC, Printer, etc) as long as I know the IP. However they just don't show up in finder.

    Cheers
    Cameron
     
  9. thread starter macrumors regular

    Joined:
    Mar 19, 2009
    #9
    Yep, I am able to connect without a problem.
     
  10. macrumors newbie

    Joined:
    Feb 6, 2009
    #10
    I have a smilar problem. I have a vista desktop and a MacBook Pro. Under Leopard, the Vista would automatically show up in the Finder Shared folder. Since upgrading to Snow Leopard, I no longer get my Vista machine showing up in the Shared folder automatically. I can get to the Vista via Command K.

    My daughter has an XP laptop. When the XP machine is connected to my home network and is not "sleeping" I can get both the XP and the Vista to automatically show up in the Finder Shared folder if I re-boot my Mac. This will not work if the XP is not connected to the network.
     
  11. macrumors member

    wad11656

    Joined:
    Feb 20, 2009
    #11
    Thank you so much for the speedy replies! It's awesome to see!:D

    I just was hesitant about giving the Vista a password and was hoping there was a way around it because a different family member owns it, and would probably be frustrated/confused if I set a password on there for the 1 & only account that anyone cares to use. But I'll definitely try it out.

    Thanks!:eek:
     
  12. macrumors newbie

    Joined:
    Sep 12, 2009
    #12
    I had similar problem that the Vista PC would not show up under "Shared" in finder of Snow Leopard Mac. However, the Mac would show up under "Network" on PC. I could connect to the PC by going to Apple>Recent Items>Servers and selecting the PC... then it would show up in finder... and sometime later disappear.

    I played around with the settings on the Vista PC... and what has worked for me was changing the network settings on the Vista PC from Public network to Private network.

    Network and Internet>Network and Sharing Center... then select "Customize" link. Change "Location Type" from Public to Private.

    Now the Vista PC shows up on Mac under "Shared" in finder.
     
  13. thread starter macrumors regular

    Joined:
    Mar 19, 2009
    #13
    Unfortunately my "Location Type" is already set to private :(.
     
  14. macrumors 604

    thejadedmonkey

    Joined:
    May 28, 2005
    Location:
    Pa
    #14
    I had this same issue when Leopard first came out. I spent over an hour on the phone with Apple, before they too finally gave up and told me that the mac probably wasn't the best fit for the officeplace.

    I guess they still haven't fixed it :\
     
  15. C64
    macrumors 6502a

    C64

    Joined:
    Sep 3, 2008
    #15
    Sorry for the bump, but just in case someone else finds this topic through Google and is looking for an answer:

    I had a similar problem as described above. Here's what fixed it for me:

    XP PC: Start > Settings > Control Panel > Administrative Tools > Services

    (or wherever the Services are located on a Windows Vista/7 machine)

    Then look for the Service called "Computer Browser". By default it was disabled. I set it to Automatic and started the service. After that the PC showed up in the Finder on all my Macs in the local network.
     

Share This Page