PC Radeon 9600 or Geforce FX 5200 on a Mac?

Discussion in 'Macintosh Computers' started by Jonathan Amend, May 29, 2004.

  1. Jonathan Amend macrumors member

    Joined:
    Oct 13, 2003
    Location:
    Montreal, Canada
    #1
    Is there a way of getting the PC version of a Radeon 9600 or a Geforce FX 5200 to work on a Mac? While searching with google, all I could find was guides on how to flash Geforce 2/4 MX's.
     
  2. Jonathan Amend thread starter macrumors member

    Joined:
    Oct 13, 2003
    Location:
    Montreal, Canada
    #2
    The reason I'm asking is that I have a Quicksilver with a broken Geforce 2 MX. With Mac OS X 10.3 I can only boot it into safe mode and the system log shows that when I try to boot normally it tries to initialize the graphics card but it always reports "Graphics chip error!" and then goes into an infinite loop. Yesterday I updated it to 10.3.4 while in safe mode and I wasn't paying attention after the reboot, but to my surprise it booted fine in normal mode. At least, that's what I though. Whenever I move any windows... well, it's hard to describe and I don't know how to take screenshots on a Mac (and I'm using an old iMac keyboard so I don't even have a print screen button).

    Anyways, is there a way to shut Quartz Extreme (?) off so that it will function the same as in safe mode as a temporary solution? I also found a guide to flashing my PC Geforce FX 5200 and Radeon 9600 cards so that I could use them in the Mac, but I need the Mac ROMs to do it. If anyone has either of these cards in their Mac, could you please message me (or if you already know how to extract them, send them to me)?
     
  3. Dreadnought macrumors 68020

    Dreadnought

    Joined:
    Jul 22, 2002
    Location:
    Almere, The Netherlands
    #3
    Do you really know it is broken? It sounds to me more that your graphics card needs a firmware update! And if you go with a graphics card, take the 9600, the 5200 is loud.
     
  4. Jonathan Amend thread starter macrumors member

    Joined:
    Oct 13, 2003
    Location:
    Montreal, Canada
    #4
    Both of the cards have passive cooling. How can I do a firmware update (and once again, where can I get the ROM to do it)?
     

Share This Page