PCI combo firewire/USB 2.0 card

Discussion in 'Macintosh Computers' started by the Natetrix, Jan 13, 2005.

  1. macrumors member

    Joined:
    Nov 25, 2003
    Location:
    NJ
    #1
    I just installed a PCI Firewire 400/USB 2.0 card into my G4 (running 10.3.7). The firewire ports work perfectly but the USB 2.0 ports don't see to respond to any of my devices. All the devices are USB 1.0 but I thought 2.0 is backwards compatable. I checked by PCI/AGP profiles, through About this Mac... and it locates the card as well as the firewire but makes no mention of USB 2.0.

    Is there a driver I should install that Im not aware of? I thought 10.3 supports USB 2.0 natively. The card is mac ready, it came with a driver CD however it seems to be only for windows machines since all the files in it are cads and exe's. Any thoughts?
     
  2. macrumors 6502a

    bokdol

    Joined:
    Jul 23, 2002
    Location:
    VA
    #2
    check there web site usually they'll have updated drives or reports for problems with that card
     
  3. macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #3
    What brand/model card? It helps if you include this information when you ask for help. Actually your devices are most likely USB1.1, but yes, they should work in a USB 2.0 port.

    Mac OS 10.3.x has drivers. I know that one of the IOGear 2 port cards works fine as does the Adaptec AUA4000A. I suspect that all of the current IOGear and Adaptec cards should work fine.

    Could the card be bad?
     

Share This Page