Personal Web Sharing behind Linksys Router

Discussion in 'Macintosh Computers' started by johnnowak, Jul 26, 2003.

  1. macrumors 6502

    Joined:
    Jul 24, 2003
    Location:
    New York, New York
    #1
    Hey there. I enabled personal websharing, and it does work for anyone on the local network.

    Just type in my local IP, and its fine.

    However, it does not work for people not on the network (using the IP my ISP assigned to me).

    How can I get it working? I tried setting my router to forward port 80 to my local IP but it doesn't seem to be working.

    Do I need to disable DHCP?

    I never had a problem running a Carracho server (if I fowarded the right port and left DHCP running). Is it possible my ISP is blocking port 80? I have Optimum Online.

    If that is the case, how do I access my httpd.conf file (I believe that's the one I need, yes?) to change the port?
     
  2. thread starter macrumors 6502

    Joined:
    Jul 24, 2003
    Location:
    New York, New York
    #2
    I accessed httpd.conf and changed the port to 8000.

    Can anyone connect to this?

    http://67.84.220.207:8000/

    It should be an empty directory.
     
  3. macrumors demi-god

    szark

    Joined:
    May 14, 2002
    Location:
    Arid-Zone-A
    #3
    Works for me.

    It's not empty now, though. ;)
     
  4. thread starter macrumors 6502

    Joined:
    Jul 24, 2003
    Location:
    New York, New York
    #4

Share This Page