Phone number in iMessage

Discussion in 'iOS 6' started by drewsky5, Sep 19, 2012.

  1. macrumors member

    Joined:
    Jun 6, 2008
    #1
    I can't figure out how to add my phone number to iMessage on the iPad or on my laptop. Running 6.0 and 10.8.2, respectively. Can any one tell me what I'm missing?
     
  2. macrumors 6502a

    super tomtendo

    Joined:
    Aug 29, 2009
    Location:
    Florida
    #2
    Same here... unless its automatically synced...
     
  3. macrumors 6502a

    Joined:
    Jul 12, 2010
    #3
    Have a look in Settings>imessage>send & receive
     
  4. macrumors 6502a

    super tomtendo

    Joined:
    Aug 29, 2009
    Location:
    Florida
    #4
    yes, but this setting is the same as before. I'm seeing nothing different. Unless, like I said, it does it automatically.
     
  5. macrumors 6502a

    Joined:
    Oct 18, 2011
    Location:
    Iowa
    #5
    I just went through this. On your iPhone, go to settings - imessage - send and recieve, and make sure AppleID (at the top) is added/set.

    Once that's done (You'll probably have to log in), set the iPad up the same, and your send/receive at from the iPhone will appear as options on the iPad (Including your phone number)

    Hope this works for you. It did for me.
     
  6. macrumors 6502

    Joined:
    Oct 12, 2009
    #6
    I think I had to turn off iMessage, wait a bit, then turn it back on on the iPhone before it popped up with a message on the other deivces to allow the use of the phone number on them.
     
  7. macrumors newbie

    Joined:
    Mar 26, 2009
    Location:
    Great Britain
    #7
    This all happend automatically for me.

    After rebooting for the OS X update I got an dialog box asking if I wanted to add my phone number to Messages. I clicked yes then the next time I unlocked my iPhone it asked me if I wanted to allow my MBA access to messages.

    I havent tested to see if it works yet mind.
     
  8. macrumors newbie

    Joined:
    Sep 19, 2012
    #8
    Mine just did it automatically
     
  9. macrumors 6502

    Joined:
    Jan 18, 2009
    Location:
    Florida
    #9
    When I updated to ML 10.8.2 it just said that my number was added.
     
  10. macrumors newbie

    a4ex

    Joined:
    Jun 29, 2011
    #10
    i just had to sing out my apple id and sing in again and it worked:D
     
  11. macrumors 6502a

    Joined:
    Oct 7, 2011
    #11
    Just got done. If you don't see your number, log out of iMessage on iOS device, and sign back up, and it will be there.
     
  12. macrumors member

    Joined:
    Jun 27, 2010
    #12
    any idea if the phone number sync will allow multiple phone numbers? I have work/personal phone and ipad and would be nice if I could get messages from both phone numbers.
     
  13. macrumors 6502a

    Joined:
    Oct 7, 2011
    #13
    its all linked under your apple id...so If you have both numbers linked to 1 ID you should be able to unless that was not thought of yet...ideally should work
     
  14. macrumors member

    Joined:
    Jun 27, 2010
    #14

    i do have all 3 under the same appleid, guess I will find out later when I get a chance to get all 3 updated.
     
  15. thread starter macrumors member

    Joined:
    Jun 6, 2008
    #15
    I've logged in and out of iMessage on all of my devices and haven't had any luck yet. My phone number is associated with my Apple ID, so I'm not sure what the problem is.
     
  16. macrumors 6502a

    Joined:
    Oct 7, 2011
    #16
    iPhone must be updated to iOS6 and working.
     
  17. macrumors member

    Joined:
    Jan 19, 2009
    Location:
    NJ
    #17
    Have you shut off iMessage on all apple devices. Turned them off, waited fifteen seconds, turned them back on, then re-enabled iMessage across the devices?
     
  18. drewsky5, Sep 19, 2012
    Last edited: Sep 19, 2012

    thread starter macrumors member

    Joined:
    Jun 6, 2008
    #18
    Yep, I have tried that several times. I've turned off iMessage, turned off all of my devices and left them off for several minutes, and then tried again. No luck.

    EDIT: Not sure what happened, but it's working now! Thanks for the help everyone!
     
  19. macrumors member

    Joined:
    Jun 27, 2010
    #19
    got them all updated and both phone numbers and all emails show up on all 3 devices.

    iMessages sent to either number or the 3 emails shows up on everything. SMS texts are still limited just to the phone number they were sent to of course.
     
  20. macrumors member

    Joined:
    Feb 3, 2012
    Location:
    NY, NY
    #20
    I also had to turn iMessage off on both my iPhone and iPad. Once I turned it back on, it verified and activated the use of my cell number
     
  21. macrumors newbie

    Joined:
    Feb 12, 2009
    #21
    I know this is an old thread, but I wanted to post this in case anyone is stumbling across it as I did.

    The fix for me was Messages>>Preferences >> Accounts Click sign out. Sign in.

    Immediately showed my phone number and messages started coming in.
     

Share This Page