Photoshop CS5 Document is in use - Can’t save

Discussion in 'Design and Graphics' started by tbhatch, Oct 25, 2010.

  1. macrumors newbie

    Joined:
    Mar 12, 2009
    #1
    I recently upgraded to Adobe photoshop CS5 and I have been getting an error while trying to save a PSD file. The error says that the file is in use and I can't save it. I end up creating another copy of the file under a different name. This is a frustrating problem because it creates confusion with multiple versions of one PSD file.

    Has anyone else had this problem and is there a way to solve it?

    Thanks
     
  2. macrumors 68040

    Designer Dale

    Joined:
    Mar 25, 2009
    Location:
    Folding space
    #2
    Sometimes I get the same thing in CS3. I haven't found a work-a-round and it is inconsistent (and annoying)...

    Dale
     
  3. thread starter macrumors newbie

    Joined:
    Mar 12, 2009
    #3
    It turns out the problem is that the Mac OS has the file open to create a preview of it. Below is one solution that might help, but if it doesn’t work the only other solution is to relaunch the finder.

    Go to Photoshop > Preferences > File Handling
    And underneath "image previews - Always save"
    Make sure that "Icon" is UNCHECKED. It must be the case that this is conflicting with the Finder's own icon generation, hence the finder not "letting go" of the file.
    If you look carefully in the background now when you are saving the file, the icon disappears momentarily and re-appears - which it did not do before.
    The only side effect is that the icons in the finder now have a think white border

    Here is the link to the forum discussing the problem. Adobe is claiming its an Apple problem and not offering much help.
    http://forums.adobe.com/message/2681220#2681220http://forums.adobe.com/message/2681220#2681220
     
  4. macrumors regular

    Joined:
    May 1, 2005
    #4
    Similar to the solution you provided, I have found that I get the "file is in use" warnings when I have a Finder window open in "Column" mode, and the file I am attempting to overwrite is the highlighted file in the finder.

    You are correct, it is an icon/thumbnail glitch. All I do is just deselect the file in the finder window and re-save.
     

Share This Page