Photoshop G5 plugin won't install on 2.5GHz G5

Discussion in 'Mac Apps and Mac App Store' started by phillymjs, Aug 27, 2004.

  1. phillymjs macrumors regular

    Joined:
    Jul 18, 2002
    #1
    Anyone else using Photoshop 7 on a 2.5GHz dualie? I've noticed that the Photoshop plugin for the G5 flat out refuses to install, telling me "You need a G5 processor to use this," or something like that before quitting.

    I imagine it's because the installer is old and doesn't "know about" the newer model G5s, thus rejecting them as non-G5 machines. A copy of the plugin installer was even included on the OS X install disc that came in the box with the G5, IIRC, but that one didn't work either.

    Does anyone know of a hack to get this installer to recognize the 2.5GHz G5, or at least a means to extract the plugin from the installer without a 'supported' G5 machine handy?

    If all else fails, would someone with an older G5 who has a copy of the plugin sans installer make it available by itself so I can grab it?

    Of course, if the installer won't even install it I guess there's a chance it won't work for whatever reason, but I'd like to find out for sure.

    Thanks,

    ~Philly
     
  2. Lancetx macrumors 68000

    Lancetx

    Joined:
    Aug 11, 2003
    Location:
    Texas
    #2
    There has been an ongoing discussion about this on Adobe's forums. Apparently Apple bundled the old version of the updater (1.04) with the 2.5s that is not compatible. A new version compatible with Rev B Power Mac G5s was supposed to have already been posted for download on Adobe's site, but as of early this morning that has not happened yet. Should be any day now though hopefully as Adobe has been made aware of the problem.
     
  3. Lancetx macrumors 68000

    Lancetx

    Joined:
    Aug 11, 2003
    Location:
    Texas

Share This Page