Photostream not capturing all my photos?

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Gregintosh, Nov 11, 2011.

  1. macrumors 65816

    Joined:
    Jan 29, 2008
    Location:
    Chicago
    #1
    I have had an issue where sometimes a picture I take with my iPhone does not get uploaded to my photo stream. For example, I was in the park and took about 6 pictures. 1 of them never made it to Photostream even though it is still on my phone.

    Yesterday, I snapped another picture somewhere and it is still not on my photo stream (even though it remains on the phone).

    My question is, is there something that causes this bug? The only thing I can think of is possible double hitting the home button and taking the photo when it was locked. Though I am not sure if that is what I did for the photo a while ago, but it is on the one I took yesterday.

    Also, is there any way to force a photo from the camera roll to Photostream so I can get the missing two photos in there?
     
  2. macrumors 6502a

    thunderbunny

    Joined:
    Jul 15, 2010
    Location:
    Cheshire, UK
    #2
    But I can live with that
     
  3. macrumors newbie

    Joined:
    Jul 26, 2009
    #3
    Having the same problem and haven't found a fix yet.:mad:
     
  4. macrumors 6502a

    thewhitehart

    Joined:
    Jul 9, 2005
    Location:
    The town without George Bailey
  5. macrumors 6502

    Joined:
    Mar 23, 2009
    Location:
    Australia
    #5
    That happened to me, but when I power cycled my iPhone, the ones that got stuck got added.

    Happens to my calendar sometimes too (add things to iCal but then it doesn't come on the phone/iPad properly until a power cycle, used to happen more on MobileMe, I thought it was because I had JB devices though.)
     
  6. macrumors newbie

    Joined:
    Dec 16, 2011
    #6
    Same problem

    I have the exact same problem on my iPad2. I import pictures from a camera and random pictures does not end up in the photostrem. Very anoying. Anyone found a soulution for this, or at least found a way to forece the missing pictures to the photostream?

    My "best" solution to solve this at this point is to upload the missing pictures to my dropbox and then download them from there. The pictures will be double stored on the iPad, but will appear only once in the photostream. It works but are not very convenient.
     
  7. macrumors regular

    Joined:
    Apr 10, 2010
    #7
    Same issue here. Rare but annoying.

    iPhoto doesn't always download all the pictures, even though my iPhone says they're in photo stream...

    And I too, have the iCal issue where sometimes events don't make it to my iPhone from iCal, or they appear on my iPhone but not others that I'm sharing a calendar with.

    Likewise, the calendar issue seemed to happen more frequently on MobileMe, but I still can't say that iCloud with photo stream and calendaring is 100% reliable, which is a shame since Apple said they're very serious about the cloud this time around.
     
  8. macrumors 601

    Joined:
    Jun 29, 2010
    #8
    I am having this same problem, not all my photos actually only 5 out of my 75 pics on my iphone are being loaded to my iPad what gives?
     
  9. StumpyBloke, May 25, 2012
    Last edited: May 25, 2012

    macrumors member

    StumpyBloke

    Joined:
    Apr 21, 2012
    Location:
    England
    #9
    Mine has completely stopped working today.

    To add: iCloud calendar sync is down too...no errors, it just doesn't sync from any to any device.
     
  10. macrumors regular

    Joined:
    Jun 2, 2012
    #10
    I've noticed mine skips or misses pics to photo stream when my signal is weak. If I have 3-5 bars of 3G I hardly miss any pics, 1-2 bars and some don't make it, if I'm on wifi the pics are there almost immediately.
    I haven't really gone and tested it, just something I've observed. Also with HDR on, my pics take longer to upload to PS over 3G because its really like 3 photos combined and the normal pics upload quicker.
     
  11. macrumors regular

    Joined:
    Apr 10, 2010
    #11
    Now, see, that's really interesting considering the fact that Photostream does not upload at all over 3G.
     
  12. macrumors regular

    Joined:
    Jun 2, 2012
  13. macrumors regular

    Joined:
    Apr 10, 2010
    #13
    Then you can't really complain it not working consistently when you're jailbroken and using unofficially-supported functionality.
     
  14. macrumors regular

    Joined:
    Jun 2, 2012
    #14
    I didn't know I was complaining, was just sharing my experience. I don't even really keep photo stream on all the time anyway, I prefer to sync my photos manually.
     
  15. macrumors 68000

    Bengt77

    Joined:
    Jun 7, 2002
    Location:
    Europe
    #15
    I have enabled Photo Stream. But I have it set to not automatically upload my new photos, as I like to add them manually after reviewing, deleting and maybe editing some of them. However, since this week photos I add manually aren't appearing in my Photo Stream anymore. I've updated to Aperture 3.3.2 yesterday. Could this new update have anything to do with this issue? The manually added photos appear to be added, when I look at the Activity window: all added photos take a while to upload. But after looking at my Photo Stream from both Aperture and my iPhone, said photos are nowhere to be found. I've tried adding some photos three times in a row, thinking that maybe I was doing something wrong. But clearly I'm not. What the heck is happening?
     

Share This Page