Play/Pause, Skip, Back won't work on keyboard

Discussion in 'iMac' started by oacory, Nov 19, 2012.

  1. macrumors regular

    Joined:
    Jun 11, 2008
    Location:
    New Jersey
    #1
    I am using a Mid 2010 21.5" iMac running Mountain Lion. I recently had my HDD replaced by Apple because of the recent 1TB Segate Drive recall and now I cannot use my pause/play, skip, and back buttons on my wireless keyboard. I can use them as function keys but nothing else. I can change the brightness and change the sound using the keyboard but I cannot skip or pause a song or video or anything like that except for using a mouse and clicking on the next button or using my iPhone as a remote which only goes so far. I have tried using multiple programs, iTune, DVD Player, VLC Player and all are not able to be controlled by the keyboard and yes I made sure this programs were on top. I am sure this simply has to be a simple setting somewhere but I am not sure where it would be. The only like setting that I saw close to what I was looking for was changing it so I need to use the function button every time I want to use a function like the sound or expose. I tried with this both on and off but can't get it to recognize the play functions. Please help me. Any advice is appreciated.
     
  2. macrumors newbie

    Joined:
    Jul 23, 2012
    #2
    Always use the latest version of the firmware for the keyboard.

    http://support.apple.com/kb/DL957

    Alternatively try trashing the preference file (com.apple.bluetooth.plist) located in Macintosh HD>Library>Preferences and then do a restart - or even try to reset the PRAM (holding Command, Option, P and R), I think you will need a wired keyboard for that though.

    Other than that maybe try to create another user account (or simply enable the Guest user) and try to the media keys there.

    Hope any of this helps, best of luck!
     
  3. thread starter macrumors regular

    Joined:
    Jun 11, 2008
    Location:
    New Jersey
    #3
    tried that

    I just tried all of that with no luck. Thanks for the suggestions. Anyone else have any ideas?
     
  4. thread starter macrumors regular

    Joined:
    Jun 11, 2008
    Location:
    New Jersey
    #4
    Any other ideas?

    I tried updating my keyboard firmware and it tells me I have a newer version, I replaced batteries, I have done a few different things and I cannot get my play/pause/forward/back buttons to work but volume and letters work with no problem. I also noticed that my expose does not work either
     
  5. macrumors member

    Joined:
    Dec 17, 2007

Share This Page