Please Help Me!!!! (dock reverts back and other problems)

Discussion in 'macOS' started by cwedl, Dec 12, 2005.

  1. cwedl macrumors 65816


    Jun 5, 2003
    I love my mac, I have no problems with it, Spoke too soon! ......

    Every time I turn my computer on, the dock reverts back to how it was when first installed it, my itunes play list corrupts, all the programs revert back to how they were when I first installed them i.e. in office I turn the project manager thing off at start up and it appears again.

    Microsoft Messenger goes back to the setup screen again. My keychains corrupt.

    My computer was working great since I installed Tiger the day it came out, whenever that was.

    Today I was in the library, I installed some widgets i.e. Google maps (which happened to quit unexpectedly) could it be these? It worked fine then I turned it off, turn it on about 1 hour later and there it was, corrupted.

    What I've done so far

    1) Repaired keychain
    2)Put all programs back in dock
    3)went through all programs again to set them up how I liked them
    4) set up microsoft messenger said that I wanted to put the icon in the dock, and the dock dissapeared and came up how it did before.

    I use backup 3 that backs up keychains and itunes library list on my .Mac account so I will hopefully beable to restore it, but there must be something wrong? Do I have the first mac virus?:eek:
  2. kdawg macrumors regular


    Dec 14, 2004
    stupid question.. but have you tried repairing your permissions?
  3. Doctor Q Administrator

    Doctor Q

    Staff Member

    Sep 19, 2002
    Los Angeles
    The new widgets are the chief suspects, so I would remove those widgets and restart, to see if the problems disappear as quickly as they appeared.
  4. cwedl thread starter macrumors 65816


    Jun 5, 2003

    Sorry for the late response, I fixed permissions, verfied the disk, all okay. I verfied the keychain all okay.

    Safari doesn't work now, keeps quiting, so I had to use my windows pc!

    I made a backup of my keychain and itunes library but it can't seem to restore them.
  5. cwedl thread starter macrumors 65816


    Jun 5, 2003
    The widgets have returned back to default, none of the widgets I installed are there, in fact them I press F12 the 4 widgets that you get when you first install the operating system are there on the dashboard!

    Edit: My keychain has just corrupted for no reason.....?

    Repair started
    Checking keychain configuration for Christian Wedlock (user ID=501)
    Home directory is /Users/christianwedlock
    Checked login keychain
    Keychain ~/Library/Keychains/login.keychain has an incorrect database version ID
    Keychain ~/Library/Keychains/login.keychain appears to be damaged
    Renamed /Users/christianwedlock/Library/Keychains/login.keychain to /Users/christianwedlock/Library/Keychains/login_renamed 1.keychain
    Created login keychain
    Checked default keychain
    Checked contents of ~/Library/Keychains/login.keychain
    Problems successfully repaired
    Repair completed

    Thought I'd post my less Rushed post on apples forums

    I've had Tiger installed the day is came out and have had no problems really, However this evening when I turned on my 12" powerbook the dock had reset, all my bookmarks in Safari had dissapeared, microsoft office had reset e.g. I disabled the gallery at start up, but it appeared again.

    All my widgets I had installed disappeared.

    I repaired the keychain because it was corrupt, verfied the disk and repaired permissions. I put all the apps in my dock again. Clicked on microsoft messenger I had to set it up again, I said add the app to the dock, the dock then reset, the keychain corrupted again, Safari didn't work, It works now because Tiger reset itself again.

    What could have coursed this?

    1) In the morning I turned my computer off, and it said it neaded to recover disk space, I said yes but was running late so I had to close the lid and put it in my backpack. When I was in the library later I turned it on and nothing was happening so I quickly turned it off. Turned it back on and all was fine.

    2) In the library I was using the wireless network in the library, microsoft messenger wouldn't sign in probably some firewall issues, I then installed some widgets, this UK TV one for whats one, Goggle maps (which unexpectedly quit!), IMDB, and Wikipedia. I turned the computer off when I left the library all was fine.

    When I went home it all went wrong, The dock reset etc... as disscussed above.

    Every time the computer is turned off, everything resets, and I mean everything, all my widgets have dissapeared! My iTunes library list have been damaged!

    Randomly the keychain corrupts, Luckly I have backed up my keychains, my iTunes list on my iDisk using backup 3 and only started last night, would this have caused anything?

    Please help
  6. cwedl thread starter macrumors 65816


    Jun 5, 2003
    Well, all my work I did to day is corrupt, a new user folder hasn't been created as said on apples site, If no one can help, I will have to put my powerbook away until I go home on the 23th and will have to install fresh tiger.

  7. Doctor Q Administrator

    Doctor Q

    Staff Member

    Sep 19, 2002
    Los Angeles
    It sounds to me that Mac OS X has lost track of your user identity or that one of the files used during login was damaged, so you were logging it but unable to get at your personal settings. That's why everything seemed to have reverted. It didn't really revert - without your own settings it was like logging in as another (new) user.

    It may very well be that your personal setting files are intact, just not being accessed. That may help explain the behavior, but not what caused it or what you should do about it next.

    You might want to post a link to the Apple discussion thread you were reading, in case somebody here can add some insights.

    Do you get all these symptoms if you log out and log back in instead of restarting?
  8. mjstew33 macrumors 601


    May 29, 2005
    Make a new account and see if it does it. If it does, I have no idea.
  9. cwedl thread starter macrumors 65816


    Jun 5, 2003
    Well thanks you everyone that helped, The problem was because of file vault, as soon as I turned it off, everything was fine again. I find it weird that most of my documents were okay just all of my preference files were corrupt.

    One word of advice to people that use file vault, back up your work!

Share This Page