Please help me recover a volume

Discussion in 'Mac Basics and Help' started by EasyB, Sep 20, 2005.

  1. EasyB macrumors member


    Jan 29, 2005
    I have a external generic compUSA 3.5 FW enclosure for a Seagate Barracuda. Things worked great until I noticed one day that I was not mounted. I tryed putting the HD in a different enclosure and it made no difference. I can not get the drive to mount. Disk utility shows the drive, but it will only allow me to erase it. Disk warrior does not even see it. I have access to Nortin, But I am afraid to put it on my system, I heard it would slow it down.

    Any ideas? Please help, I would hate to loose my data. Also do you think the enclosure could of caused the problem?

    My setup is The latest powerbook running the latest OSX

  2. mklos macrumors 68000


    Dec 4, 2002
    My house!
    Try Norton...anything is worth a shot at this point. When you're finished, just uninstall it.

    I'm surprised that DiskWarrior didn't find the drive when Disk Utility did.

    If DiskWarrior didn't find it, then you may be SOL. Can you get your hands on TechTool Pro 4 for OS X? That is great alternative to DiskWarrior. Its gotten me out of a few hiccups before.
  3. CanadaRAM macrumors G5


    Oct 11, 2004
    On the Left Coast - Victoria BC Canada
    You don't want no steenking Norton on your OSX machine.

    It is a DUDD -- Deceptive Utility of Data Destruction

    Try DiskWarrior again -- you are booting from the DiskWarrior CD, are you not?

Share This Page