Please Help, PB won't boot.

Discussion in 'Macintosh Computers' started by Hockey Nut, Jul 2, 2004.

  1. macrumors member

    Joined:
    Feb 15, 2003
    Location:
    Battle Creek
    #1
    I have a 12 PB running 10.2. My daughter spilled some milk on it, not a lot I don't think, but it won't boot. When I press on the power button, the power cord color goes from orange to green. I can hear the hard drive start to spin, but it stops almost immediately.
    I tried removing the battery and holding the power button for 30 seconds to no avail.
    Any suggestions?

    Thanks.
     
  2. macrumors 68020

    Horrortaxi

    Joined:
    Jul 6, 2003
    Location:
    Los Angeles
    #2
    Don't turn the computer on until you know all the milk is dried/gone. Mop up what you can get to and let the rest evaporate. Aim a fan at the computer if you like. It might take a couple days, depending on how much got in. Then try to start the computer.

    Starting a wet computer is bad because the milk will conduct electricity and short out important parts of the computer.
     
  3. macrumors 6502a

    JOD8FY

    Joined:
    Mar 22, 2004
    Location:
    United States
    #3
    I just wanted to point out that the power cord always goes from orange to green to orange when you start it up. It does the same thing when you wake it from sleep.

    When you try to start it up again, try holding down the "x" key while it's booting. This forces OS X to start up.

    Good luck,
    JOD8FY
     
  4. macrumors 6502a

    comictimes

    Joined:
    Jun 20, 2004
    Location:
    Berkeley, California
    #4
    I don't know if this is the same thing, but, other than the color of the power cable (I never noticed what was happening to it), this pretty much describes what went on with my powerbook for a while. For me though, after a bunch of tries, the computer just randomly turned on. I don't know what causes it to finally turn on, but it happened to me 2 or 3 times....
     
  5. macrumors 6502a

    JOD8FY

    Joined:
    Mar 22, 2004
    Location:
    United States
    #5
    Check your Energy Saver settings in System Preferences. You may have it set to turn on automatically.

    JOD8FY
     

Share This Page