Plex server going to sleep while streaming to TV

Discussion in 'OS X Mountain Lion (10.8)' started by Tonsko, Jun 13, 2013.

  1. macrumors 6502

    Joined:
    Aug 19, 2010
    Location:
    UK
    #1
    Wonder if you can help.

    I'm running this, and around about 30-40 minutes in, the plex server shuts down.

    I've tried running it with caffeinate thus:

    alias plex='caffeinate -i open -W -a "Plex Media Server.app" &' and put it into my .bash_profile so that I can run it easily - but even with caffeinate it shuts down.

    Any ideas on how I can stop it doing this?
     
  2. macrumors newbie

    Joined:
    Oct 27, 2008
    #2
    I have this problem too. Anyone know of a solution?
     
  3. macrumors newbie

    Joined:
    Oct 25, 2014
    #3
    I just wrote a little wrapper shell script to use caffeinate while the Plex Transcoder is running as I found that the Transcoder is running even when I'm watching on my XBOX ONE, Amazon Fire TV and of cause on my iPad.

    Here is a little howto:

    Go into /Applications/Plex Media Server.app/Contents/Resources

    Rename "Plex New Transcoder" to "Plex New Transcoder Real"

    Create a shell script "Plex New Transcoder" :

    #!/bin/sh

    /usr/bin/caffeinate -i '/Applications/Plex Media Server.app/Contents/Resources/Plex New Transcoder Real' "$@

    chmod 755 on the new script

    I think it would be great if there was an option to use caffeinate with the transcoder out of the box but this hack did the trick for me.
     
  4. macrumors newbie

    Joined:
    Nov 9, 2014
    #4
    Could you elaborate a little more how to do shell script. I've had the same problem, have been playing around darkwake, but mac goes to sleep every minute, when screen is off, and is just streaming. Thanks.
     

Share This Page