1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

PMG4 Quicksilver DP 1ghz 512mb Won't Boot

Discussion in 'PowerPC Macs' started by trojanlimit, Feb 22, 2008.

  1. macrumors newbie

    #1
    Hey guys,

    I searched google for this and came across a relevant article and I believe the solution might be to get a new pram battery (suggested radioshack), but I'd like to get some second thoughts.

    I recently acquired a dual processor 1ghz powermac g4 quicksilver with what seems to be 512mb ram, and an upgraded 200gb harddrive. I had to buy a new power cord from radio shack because it didn't come with one but when I turn it on, i see a glowing white light behind the power button that fades away almost immediately. I hear (and see when i pulled down the side cover) the fan moving, and a little red led light shines bright on the motherboard, but the harddrive does not spin up. I'm not sure if the optical drive turns on either. I tried messing with the jumper settings and switching the cables in the computer but nothing worked. I put the drive in an external enclosure and it mounted fine, so i have no doubts on the drive, but i was wondering if this is indeed a pram battery issue, and how much it would cost to get a new one. the other site estimated around 12-15 bucks (very reasonable considering i got the computer for free).

    Let me know as i'd love to get working on it.

    also, i believe it has two graphics cards and one has an ADC connection - are those the ones that look like dvi but are oval shaped?
     

Share This Page