port opening

Discussion in 'Mac Pro' started by stoneage, Jul 24, 2006.

  1. stoneage macrumors regular

    stoneage

    Joined:
    Sep 21, 2002
    Location:
    Directly above the center of the Earth.
    #1
    I can't open a port in the Sharing/System Pref Pane on my G4 iBook (10.4.7). I can click on Edit... on existing ports, but am unable to create a new one. I was trying to open up 5052 for DropCopy. The button activates when I click on it, but nothing happens.
     

    Attached Files:

  2. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #2
    Are you an admin on the box?
    Tried logging in as another admin user to see if it works there?
    Tried turning the firewall OFF before editing/adding new holes?
     
  3. stoneage thread starter macrumors regular

    stoneage

    Joined:
    Sep 21, 2002
    Location:
    Directly above the center of the Earth.
    #3
    I am admin, and I tried it with the firewall off. I can click the button, it highlights, but nothing happens.
     

    Attached Files:

  4. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
  5. stoneage thread starter macrumors regular

    stoneage

    Joined:
    Sep 21, 2002
    Location:
    Directly above the center of the Earth.
  6. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #6
    You need to add a new service in the firewall tab (i think) then you can specify the ports you want to open.
     
  7. stoneage thread starter macrumors regular

    stoneage

    Joined:
    Sep 21, 2002
    Location:
    Directly above the center of the Earth.
    #7
    That's what I can't do.
     
  8. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #8
    If you can't do it from a newly created (admin) user, it's an indicator of a deeper problem. What do the logs indicate as a problem (if anything)?
     
  9. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #9
    You could always try simply switching off the firewall temporarily and see if that helps.
     
  10. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #10
    He tried that.
     
  11. Coheebuzz macrumors 6502

    Joined:
    Oct 10, 2005
    Location:
    Nicosia, Cyprus
    #11
    Try trashing 'com.apple.sharing.firewall.plist' from your Preferences. That may help.

    Also can you use the Terminal to open/close ports in the Firewall? Can't tell you how but it will help to isolate the problem.
     

Share This Page