Possible Problem with Photostream, iPhone 4S, and iPhoto 9.2

Discussion in 'Apple Music, iCloud and Apple Services' started by timotay89, Oct 14, 2011.

  1. macrumors regular

    Joined:
    Jul 20, 2011
    #1
    So, the photostream feature on iPhoto on my mac seems to hold only 1,000 pictures. I have taken enough to add a few to photostream on the mac with my new iPhone 4S, but they don't seem to want to make the leap to my laptop.

    On the iPhone, photostream has stopped syncing at a random 461 photos. No more will load (but the new ones I took are on photostream on the iPhone, but not on my laptop).

    I just want the recent 1,000 on the iPhone and all of them on my laptop.

    Am I missing something or is this Apple's fault?
     
  2. macrumors newbie

    Joined:
    Oct 15, 2011
    #2
    Hi,
    i seem to be having the same issue. Photo Stream will upload photos from my iPod Touch, and also on my PC or Mac, but not upload from iPhone 4s. I thought this only affected my dad's iPhone 4s, but I just tested it with my iPhone 4s & it wasn't working. Photos put into Photo stream folder on PC or iPhoto on Mac will appear on the iPhone, but photos taken by iPhone will not appear. Funnily enough, screen captures does appear on Photo Stream.

    This was done on 2 separate Apple IDs on iCloud. One for my dad's iPhone, mum's iPad and on PC. Another separate Apple ID for my iPhone, iPod touch & Mac.

    Does anyone know how this can be resolved? i've tried deleting iCloud accounts on iPhone & entering the details again. i've also disabled and reenabled Photo Stream on all my devices. And i've also tried activating "Automatic downloads". All to no avail.
     
  3. macrumors regular

    Joined:
    Aug 1, 2010
    #3
    Works fine on my iPhone 4S, but iPhoto on my iMac refuses to upload and sits there doing nothing.
     
  4. macrumors newbie

    Joined:
    Oct 15, 2011
    #4
    Do you mean that u can upload photos on ur iMac and it'll show on ur iPhone. but not the other way around? because that's exactly the problem i have.
    i can upload via my iPhoto on MBP, and photos will appear on the Photo Stream album on the iPhone. But when i take a photo on the iPhone, it won't appear on iPhoto.
    and like i said. it seems to be fine with screen dumps, just photos... :confused:
     
  5. macrumors regular

    Joined:
    Aug 1, 2010
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    It doesn't work on the Mac full stop. It says, for example, "11 Pictures Uploaded" yet does nothing but display the Photostream instructions. They're not uploaded anywhere, and I cannot see my existing PS on Mac.

    iPhone, on the other hand, is fine. It sends everything to Photostream.
     
  6. thread starter macrumors regular

    Joined:
    Jul 20, 2011
    #6
    Update!

    So, this morning when I looked at this thread, my mac was (apparently) downloading the photos from photostream. It downloaded them all and they were fine. If I took a picture, it sent it right away, no problems. Even when I took 50+ in a row really quickly because I was bored.

    anyways, so I ttok some pictures later (while on wifi) and then later some while not on wifi. I've been home for hours now and nothing. The phone says they are uploaded, but the aren't on photostream on my mac.

    I'm thinking it's either:
    1. Apple is going through and doing something that makes it only work sometimes.
    2. It's (somehow) set to only work during different times of the day.
    3. I'm doing something stupid without realizing it.

    Anyone else have it work for a couple of hours today just to have it not work now?
     
  7. macrumors regular

    Joined:
    Aug 1, 2010
    #7
    Mine is, ironically, working fine now. I put it down to having restarted the computer. It seems that a lot of the things need restarts (Wifi sync, for instance, needed me to restart iTunes and my iPhone)
     
  8. macrumors newbie

    Joined:
    Mar 19, 2011
    #8
    tons of iCloud problems

    i too have had tons of problems with photostream, and other iCloud glitches.
    What ever happend to "It just works"? Wasn't this supposed to be Apple's chance to redeem itself after the fiasco of MobileMe?
     
  9. macrumors newbie

    Joined:
    Feb 6, 2012
    #9
    Try connecting to wi-fi

    I believe I read somewhere that you must be connected to Wi-Fi to upload photos to Photo Stream. Try it out.

    I just did, and it solved it for me.
     
  10. macrumors newbie

    Joined:
    Mar 22, 2012
    #10
    Hey Guys,

    Have seen quite a few people having this problem and the solution is quite a simple one - none of the i-devices will do the photostream sync if battery level is under 20%. This is true even if you are charging your device but your level is under the required 20%. This would explain why it's sometimes an "intermittent" problem as people's charge levels fluctuate. So make sure the device that the original photo and the recipient devices are all charged above 20%.

    Let me know if that helps any of you?

    Cheers.
    C.
     
  11. macrumors newbie

    Joined:
    Apr 9, 2012
    #11
    I noticed the same 20% issue.
    Additionally, the upload did start again only after taking another picture, which triggered the process. Maybe taking a Screenshot is enough.
    Nik
     

Share This Page