Possible to disable iCal alarms?

Discussion in 'Mac Basics and Help' started by superwoman, Apr 15, 2006.

  1. superwoman macrumors regular

    Apr 25, 2005
    I have a Treo 650, and I use Missing Sync to sync to my Mac.
    I don't need iCal to alarm me, my Treo does that perfectly fine.
    So is it possible to disable iCal's alarm feature?
  2. blodwyn macrumors 65816

    Jul 28, 2004
    Portland, Oregon
    iCal preferences. Check the 'Turn off alarms when iCal is not open' box, and as long as you have iCal closed you won't get any alarms.

    Picture 1.jpg
  3. superwoman thread starter macrumors regular

    Apr 25, 2005
    I unchecked that already. Problem is that I _do_ want iCal opened, I just don't want the alarms.
  4. Ish macrumors 68000


    Nov 30, 2004
    The 'Show Info' drawer has a section where you can turn the alarm on or off for each event. Not certain this is what you mean, though, as the alarms only work if you set them up. Is this what you want?
  5. superwoman thread starter macrumors regular

    Apr 25, 2005
    No, I'm afraid not. I was hoping that there's a global setting or hack to disable iCal alarms. I rely on my Treo mainly, but I do sync my calender onto my Mac, and I like to keep iCal open for the month view (try that on the Treo). I just don't need the alarms to go off on the Mac. It's a minor annoyance, because I have alarms for 80% of my daily events.
  6. koiboy macrumors newbie

    Mar 3, 2010
    More advice on turning off alarms (or, colloquially, notifications)

    Thanks to blodwyn for the suggestion to try Preferences > Advanced > Turn off alarms when iCal is not open.

    Now (years after his/her post) apple seems to have added a new option, i.e. Preferences > Advanced > Turn off *all* alarms. (Which was not present in the screen shot that blodwyn provided).

    So, try that. It might help.

    In spite of that suggestion there are some caveats:

    I created a test calendar entry with like 7 alarms each 1 minute apart and then selected "Turn off all alarms." The alarms kept popping up! Argh. Then I thought maybe this is because I created the event *before* selecting "Turn off all alarms." So, I made sure "Turn off all alarms" was truly set and *then* created another event with like 7 alarms. These alarms did not go off. This suggests my hypothesis is correct.

    However, if my hypothesis is correct I am still suffering from this iCal misfeature. This is because I have a presentation on Friday. I have *years* worth of reminders that go off at random times already on my computer. These will (according to my hypothesis) continue to go off even now that I have selected "Turn off all alarms" because, of course, they were created long before I made that selection.

    So, wish me well when I give my presentation when the audience sees lots of random reminders! (Or else I will have to painstakingly delete them beforehand).

    Alternatively, perhaps my hypothesis is incorrect and I have actually succeeded in turning off my alarms once and for all. (But then why did I get the above behavior with my two test calendar entries?)

    As the hours / days pass by I will no for sure whether I have truly silenced my alarms so I do not have to embarrassed by random personal reminders popping up while people are seeing my screen.

    One more pointer (which might help google searchers like me find this advice?):

    I was wanting to turn off the alarms on my system. I got confused because at first I thought they were notifications and so I would go to View > Hide Notifications and would frustratingly still get the stupid things popping up...for months / years!! Now, on this the n-th attempt I realized it was probably not notifications I needed to disable but alarms.

Share This Page