Post some Lion bugs that you have encountered!

Discussion in 'Mac OS X Lion (10.7)' started by AlphaDogg, Mar 1, 2011.

  1. macrumors 68040

    AlphaDogg

    Joined:
    May 20, 2010
    Location:
    Boulder, CO
    #1
    Do as the title suggests.

    The major one that I have encountered: Audio drivers.

    Here is my situation. I boot up my MBP, its great. Then I hook it up to my desk (with 3.5mm audio included). I turn up the volume and I hear some sort of clicking... I can't really explain it. I unplug the speakers, and the issue persists. The only way to fix it is to reboot. I will take a recording of the audio soon.

    Other issue: Sometimes the ambient light sensor doesn't work, and I have to force the keyboard backlight with Lab Tick.
     
  2. macrumors member

    87racer

    Joined:
    Nov 15, 2010
    Location:
    Oregon
    #2
    found this on another post "go to Audi MIDI Setup, then change the format to "2-ch 32-bit."
     
  3. macrumors 6502a

    Joined:
    Jan 15, 2010
    Location:
    east coast
    #3
    Well I have had a few issues with time machine dropping out on the middle of a back up. Not sure if it was lion related or Macbook related...restarted both and seems fixed for now.
     
  4. thread starter macrumors 68040

    AlphaDogg

    Joined:
    May 20, 2010
    Location:
    Boulder, CO
    #4
    I'm not sure I understand what you are trying to say here...
     
  5. macrumors member

    87racer

    Joined:
    Nov 15, 2010
    Location:
    Oregon
    #5
    In your utilities folder there is an app call Audio MIDI Setup. Make sure you select your built it output.
     

    Attached Files:

  6. macrumors regular

    Joined:
    Jul 8, 2006
    Location:
    Baton Rouge, La.
    #6
    iCal won't stop freaking opening.

    Does anyone have a solution for this? I've tried restarting and unchecking the "reopen windows" checkbox.
     
  7. macrumors member

    87racer

    Joined:
    Nov 15, 2010
    Location:
    Oregon
    #7
    Have you tried force quitting from activity monitor. it could be crashing on close and then trying to recover. force quitting would bypass that.

    if it keeps opening there is likely another program opening it.

    you could download a program called fseventer and close everything possible (any open programs, even stuff in your menubar) then run fseventer and click the little play button in the top left corner. then try to quit ical and let it reopen. then click the little pause button. take a screenshot(command+shift+3) and post it here.

    also, did you install over SL or do a fresh install to another partition?


    -----------------------------------------
    Mac OS X Lion Adventures.
    Issues, Solutions, and Workarounds
    http://www.bs87.com
    -----------------------------------------
     
  8. macrumors regular

    Joined:
    Jul 8, 2006
    Location:
    Baton Rouge, La.
    #8
    I've tried force quitting, but it doesn't work.

    I'll download fseventer and let you know the results.

    This was a install over SL.
     
  9. mdickson, Mar 1, 2011
    Last edited by a moderator: Mar 5, 2011

    macrumors regular

    Joined:
    Jul 8, 2006
    Location:
    Baton Rouge, La.
    #9
    Here's the relevant calendar stuff. A DNLA server running is filling up the rest of the log.

    [​IMG]
     
  10. macrumors 6502a

    Joined:
    Jan 14, 2009
    Location:
    UK
    #10
    personally finding Lion stable enough for daily use, haven't found any major life threatening bugs (yet) - except Evernote does not work at all, and Twitter is stuck on top of all windows if i tell OSX to re-open it on Login - i think the applications just need save and resume capabilities :confused: :D while i am a little disappointed with the minimal number of 'real' features in the new OS it has polished off and refined many of my most important apps and i hope we still have much more to come! p.s. i want full-screen support for iTunes, come on Stevie don't disappoint!!!
     
  11. macrumors newbie

    Joined:
    Mar 1, 2011
    #11
    Racer - I actually took the time to create a MacRumors Forums account so that I could login and thank you for your post. So .. Thanks. :)

    Worked like a charm and eliminated the most annoying bug I was dealing with - thanks again!
     
  12. macrumors 68000

    ErikGrim

    Joined:
    Jun 20, 2003
    Location:
    Brisbane, Australia
    #12
    Dictionary isn't showing up when highlighting a word unless you upgraded an install that already had inline dictionary enabled. That preference now seems to have disappeared from the Dictionary app? :confused:
     
  13. macrumors newbie

    Joined:
    Oct 7, 2009
    #13
    The three most annoying ones:

    • Wi-Fi gets randomly turned off on startup and needs a reboot to get fixed.
    • iTunes and iChat don't play well with spaces and they sometimes disappear... only way to bring them back is to quit.
    • Safari randomly won't let me enter text on boxes, copy paste on Google docs... hangs up a lot
     
  14. Takuro, Mar 1, 2011
    Last edited: Mar 1, 2011

    macrumors 6502

    Takuro

    Joined:
    Jun 15, 2009
    #14
    I found a pretty gnarly bug, but one that I thought was a bit obvious to test out.

    Open Safari and enter full screen mode. Then, open multiple tabs. Drag one of those tabs out to become a new window. Mission control will then attempt to create a new space for this separate window but messes up pretty badly. A new space is created which shows only the grey background of mission control with no content or windows. After running some tests, it turns out both Safari windows are still running in the same fullscreen space, and you can toggle visibility by right clicking the dock icon and choosing which page you want to view. In one test, it shifted all other spaces one space to the left, placing windows inside the space reserved for Dashboard, which was kind of funky. To fix this, just quit Safari.

    Also, Safari in general seems to have issues whereby the Finder doesn't make the menubar unhidden when exiting fullscreen mode. To fix this, try entering and exiting fullscreen mode again.

    I'm sure both of these will be fixed sometime soon just because they are pretty glaringly apparent. There were some other major Safari bugs, like the "back" button failing to behave properly at times, but this was actually caused due to extensions I had installed. Remember, all extensions out there were written for Snow Leopard, which uses an older version of webkit.
     
  15. macrumors member

    87racer

    Joined:
    Nov 15, 2010
    Location:
    Oregon
    #15
    Have you tried shutting down your dlna server? also in fseventer you would be looking for another app(not ical) accessing an ical relevant file if not the app itself. Could you send me a private message with a save from fseventer. also what programs are in your login items menu under users and groups in system preferences?

    Glad to know it worked for you!

    is my attached picture what you are referring to?

    I to have seen wifi suddenly quit working but I am able to turn airport off and back on and it fixes it.

    I have seen the Safari bug as well and it seems like something is stealing focus from safari. Im currently waiting for it to reoccur to try and figure it out.
     

    Attached Files:

  16. macrumors regular

    billy3785

    Joined:
    Sep 3, 2008
    Location:
    NYC
    #16
    the 2 most annoying things are when iphoto and transmission crash for no reason. oh well, I know, its a beta.
     
  17. macrumors 6502

    antmarobel

    Joined:
    May 8, 2009
    Location:
    Brasília
    #17
    Please verify something on your bluetooth>mouse...does it show the correct information about the battery charge?...Mine is not on bold and is always on 100% and I'm using the batteries for more than 6 days now...:confused:
     
  18. macrumors regular

    Joined:
    Oct 24, 2008
    Location:
    Tilchestune UK
    #18
    Gentlemen and Ladies


    Please post bugs in the correct place via apples bug reporter if you are developers you should be doing this as a matter of course its BETA after all

    Apple do not read these forums so please post bug to apple

    That way we will end up with a better OS
     
  19. macrumors regular

    Joined:
    Feb 27, 2011
    Location:
    Idaho
    #19
    Agreed. Thank you.
     
  20. macrumors 6502a

    karsten

    Joined:
    Sep 3, 2010
    #20
    -moving the mouse doesn't wake the monitor (have to click or hit a keyboard key)

    -safari has lots of bugs, blank pages, stopping loading etc

    -networked computers don't show up in devices in the sidebar of finder

    -screen sharing / file sharing doesn't work


    someone should report these to apple
     
  21. thread starter macrumors 68040

    AlphaDogg

    Joined:
    May 20, 2010
    Location:
    Boulder, CO
    #21
    I have had that issue too.
     
  22. macrumors regular

    Joined:
    Jul 8, 2006
    Location:
    Baton Rouge, La.
  23. macrumors 6502a

    Graeme43

    Joined:
    Sep 11, 2006
    Location:
    Great Britain (Glasgow)
    #23
    Maybe its a feature? It does it on mine as well
     
  24. macrumors member

    87racer

    Joined:
    Nov 15, 2010
    Location:
    Oregon
    #24
    I was beginning to think it was a feature as well.
     
  25. karsten, Mar 2, 2011
    Last edited: Mar 2, 2011

    macrumors 6502a

    karsten

    Joined:
    Sep 3, 2010
    #25
    hopefully there will be a way to revert it back i think it's annoying:)

    any other problems syncing an ipod?
     

Share This Page