Power MAc G4 Display stopped working

Discussion in 'PowerPC Macs' started by Kyle456, Aug 19, 2007.

  1. macrumors newbie

    Joined:
    Aug 19, 2007
    #1
    Hi can anyone help me out. I recently got a powermac G4. When I viewed it Everything was working. Upon me hooking it back up I noticed It was not getting any picture. The Monitor was brand new so i did not figure it to be broken I checked the monitor on another computer and it worked great. From what I understand this is a common internal problem on the G4. Does anyone know how to correct this issue?

    thanks
     
  2. macrumors regular

    Joined:
    Oct 23, 2004
    Location:
    .BE
    #2
    can you give us more info on the PM?

    Model, monitor????

    is the video card / RAM seated correctly?

    does the PM start up? does the fan and HDD work?

    for a PM check the internal battery on the motherboard and try to push the little button next to it to hardboot the system (workd for me after a shutdown due to lightning)

    have you tried it with another screen?

    does the PM has a OS installed on it? :rolleyes:
     
  3. macrumors newbie

    Joined:
    Aug 23, 2007
    #3
    PowerMac g4 dual 867 at power "on"

    has anyone experienced upon "first" power-on your desktop mac a prompt "kernel error ...and series of codes appears or just hangs?"
    I have to power up my powermac for a continuous 20 mins or so...then power off then "on" just to let the apple logo appears at start-up. worse when i leave my mac idle for 10 mins...even if theres screensaver it just hangs...

    tried to test the memory in other units...works perfectly
    also replaced the battery. would it be the processor or the video card?

    Appreciate your help.

    Thanks much in advance!

    Ted
     
  4. macrumors 6502

    Joined:
    Oct 27, 2006
    #4
    zthree, you really need to start your own thread! You aren't going to get much of a response with your question about a kernel panic buried in a stale thread about a G4 monitor problem.
     
  5. macrumors newbie

    Joined:
    Aug 23, 2007
    #5
    Powermac G4 Startup Problem

    Thanks Sherman Homan
     
  6. macrumors newbie

    Joined:
    Dec 13, 2008
    #6
    powermac g4 display issue

    Hey so im having a problem with my powermac g4's display... so when i turn on the computer, everything seems to power up just fine (hard drives are spinning, fans, graphic card fan etc...) but there is just no picture on the screen! in fact, the screen doesnt even seem to be receiving anything (i.e. its still in standby mode) i tried changing monitors, and changing graphic cards, and i cant figure it out to solve the problem! if some1 knows wat to do, please lemme kno
     

Share This Page