Powerbook 17" Alum odd issues

Discussion in 'PowerPC Macs' started by Kaji79, Jul 12, 2010.

  1. macrumors member

    Joined:
    Jul 12, 2010
    #1
    Hi all long time lurker, first time poster!

    I recently picked up a powerbook with no display, and the keyboard/trackpad do not work.

    When hooking a monitor to it it works just fine. So I ordered a new screen inverter to see if I can get it working.

    The other issue I have is with the keyboard/trackpad.

    Neither work, and the odd thing is the keyboard lights up when I shut the lights off.

    Has anyone seen a nonworking keyboard do this? I have spent a few days reading, and I cannot figure out of the mouse and keyboard are combined or separate plugs. I will be cracking it open when the inverter shows up, so I will be checking the plugs.

    I figured it's a hardware issues since I have reinstalled tiger, down pram resets etc to no avail.

    Thanks in advance!
     
  2. macrumors 604

    Joined:
    Sep 17, 2009
    Location:
    Melbourne, Australia
    #2
    Is it worth getting the screen and the keyboard and the trackpad replaced? Unless its just a connection.
     
  3. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #3
    If it would be inverter, display shouldn't be completely black. You'd be able to see "something" on it.
    Check connections before ordering replacement parts. Get yourself service manual for this PB and disassembly unit to check/reseat all possible ribbons and cables display and topcase related.
     
  4. thread starter macrumors member

    Joined:
    Jul 12, 2010
    #4
    Yeah Sorry I meant to mention that I can everything if I shine a light on it :) I think it is worth since I picked it up for 20$ If it's just a 30 $ part, and a disconnected plug I can't complain for a 17" display :)
     
  5. thread starter macrumors member

    Joined:
    Jul 12, 2010
    #5
    THe odd part is the keyboard lights up but does not work. Are they separate?
     
  6. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
  7. thread starter macrumors member

    Joined:
    Jul 12, 2010
    #7

Share This Page