Powerbook batteries taking NINE hour charge - HELP!!!

Discussion in 'PowerPC Macs' started by Porksword, Sep 3, 2007.

  1. macrumors member

    Joined:
    Mar 30, 2006
    Location:
    Grand Rapids, MI
    #1
    I have two batteries and two powercords for my PB G4 17inch and all of a sudden both batteries say they will need 9+ hours charge. Tried both batts and both powercords. Reset the PMU by unplugging and holding power for 5 sec. Turn it back on, it says the time has been reset but still needs forever to charge.
     
  2. Guest

    MikeTheC

    Joined:
    Apr 26, 2004
    Location:
    Gallifrey -- Capitol City, Prydonian Sector
    #2
    Well, if you're looking to troubleshoot this...

    Find someone else with the same (or similar) model of PowerBook that you've got, and try charging the batteries in it. If it does the same thing, then it's your batteries. If not, it may be the charging circuitry in your PB.

    Also, were your batteries a part of that recall that Apple had? If they were, you may be able to get them exchanged under warranty. If not, well...
     
  3. thread starter macrumors member

    Joined:
    Mar 30, 2006
    Location:
    Grand Rapids, MI
    #3
    I didn't think any of the 17-inches were part of the recall. Am I wrong?
     
  4. macrumors 6502a

    aphexacid

    Joined:
    Jul 31, 2007
    Location:
    Chicago
    #4
    i dont think the 17" models were included. if they were, then hell, where do i sign up?
     
  5. thread starter macrumors member

    Joined:
    Mar 30, 2006
    Location:
    Grand Rapids, MI
    #5
    Also, when charged, the batteries perform as usual.
     
  6. thread starter macrumors member

    Joined:
    Mar 30, 2006
    Location:
    Grand Rapids, MI
  7. thread starter macrumors member

    Joined:
    Mar 30, 2006
    Location:
    Grand Rapids, MI
    #7
    Now I've noticed that when I'm running system intense apps, my battery may take 12+ hours to charge.
     
  8. macrumors member

    Joined:
    Jun 6, 2005
    #8
    Considered trying a friends powerbrick? Maybe yours not working properly.
     
  9. thread starter macrumors member

    Joined:
    Mar 30, 2006
    Location:
    Grand Rapids, MI
    #9
    Unfortunately I don't know anyone else with a 17-inch. But still find it odd that both of mine do the same thing.
     
  10. macrumors member

    Joined:
    Jun 6, 2005
    #10
    15 inch might do, I think they have same wattage, but you could verify if you know anyone with such powerbook.
     
  11. macrumors 65816

    Jiddick ExRex

    Joined:
    May 14, 2006
    Location:
    Roskilde, DK
    #11
    All the old models run on the same wattage so knock yourself out...
     
  12. thread starter macrumors member

    Joined:
    Mar 30, 2006
    Location:
    Grand Rapids, MI
    #12
    I've tried 4-5 different power cords all with the same result. I think I may have a bad logic board/PMU. I may have to bring it in. :mad:
     

Share This Page