PowerBook Ethernet Slow?

Discussion in 'Macintosh Computers' started by kbonnel, Apr 27, 2004.

  1. kbonnel
    Expand Collapse
    macrumors 6502

    Joined:
    Mar 1, 2004
    Location:
    In a nice place..
    #1
    Hello All,

    So, I was playing around with my PB15", and started doing some dslreports.com speed tests. For some reason, I am only getting a speed score of 2500 (tops), when my other machines (Windows/Linux) are getting a score of 3000+. My Internet connection is a 3meg cable. No matter what I do (different cables, direct switch connection, etc), I only get a speed of around 2500. Of course, I know that this is great speed, and I am not saying otherwise, just wondering.

    Anybody know if the ethernet in the PB has issues?

    Kimo
     
  2. mactastic
    Expand Collapse
    macrumors 68040

    mactastic

    Joined:
    Apr 24, 2003
    Location:
    Colly-fornia
    #2
    Not as far as I know. It should be a Gigabit ethernet, and as such should be capable of exceeding your 3Mbit internet connection by far.
     
  3. kbonnel
    Expand Collapse
    thread starter macrumors 6502

    Joined:
    Mar 1, 2004
    Location:
    In a nice place..
    #3
    That is my thought. it is very strange. I wonder if it is safari and it's java implementation.

    Kimo
     
  4. beerguy
    Expand Collapse
    macrumors regular

    Joined:
    Aug 20, 2003
    #4
    If you're getting 2500 on a 3000 line that's pretty good. The rating is what it's capable of, your test is actual data. TCP/IP frames contain more then just data, which is what your test is looking at. There is no such thing as a 100% efficient connection.
     
  5. kbonnel
    Expand Collapse
    thread starter macrumors 6502

    Joined:
    Mar 1, 2004
    Location:
    In a nice place..
    #5
    I know it is good. But for some reason, my PB only gets 2500, while my other machines get the 3k...

    Kimo

     
  6. Westside guy
    Expand Collapse
    macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy part of the Pacific NW
    #6
    You don't say what the processors are.

    Okay, I'm at work w/ a 100mb line...

    PB 15 1.25GHz running OS X 10.3.3 : 16603kbps down, 7784kbps up

    Dell Dimension 2.4GHz running Fedora Core 1: 20473kbps down, 7573kbps up

    If I had to place a bet, I'd bet this is limited by the Java execution speed.
     
  7. JOD8FY
    Expand Collapse
    macrumors 6502a

    JOD8FY

    Joined:
    Mar 22, 2004
    Location:
    United States
    #7
    Have you tried using Internet Explorer? I know Safari is supposed to be faster, but you never know...

    JOD8FY
     
  8. kbonnel
    Expand Collapse
    thread starter macrumors 6502

    Joined:
    Mar 1, 2004
    Location:
    In a nice place..
    #8
    My PB is 1.5, and my other machines are a 2gig AMD XP and a 2.2gig AMD XP. I also ran the test with IE instead of Safari, and it is also around 2400. Very interesting. I wonder if it is Java. Oh well, just thought I would see what other people thought.

    Kimo
     

Share This Page