Powerbook G4 1.67 kernel panic-- won't boot

Discussion in 'PowerPC Macs' started by Nova77, Mar 28, 2012.

  1. Guest

    Joined:
    May 12, 2011
    #1
    :S Need help, my powerbook wont boot! kernel panic everytime..

    I tried to remove 1 RAM bar, and then the other, nothing happened.

    I tried a diff OS that was on same HDD... same

    I reinstalled (clean install) of Tiger on an external firewire 800 drive, and it won't boot either.

    What do I do?
     
  2. macrumors 68020

    zen.state

    Joined:
    Mar 13, 2005
    #2
    Can you please give more specifics of exactly what happens when you try to boot and how far it gets before the KP. Is it consistently at the same time in the boot process? Is the KP instantaneous?
     
  3. thread starter Guest

    Joined:
    May 12, 2011
    #3
    Thanks for response.
    Well the computer boots to the progress bar, it loads, the user window shows up, and then you have 3 seconds to type in the start of your password... then BOOM. Kernel panic, sometimes with weird flashing colors.

    It happens exactly at the same time everytime in the boot process.

    The computer boots in safe mode, but this is unsuable since everything is turned off.

    I don't see how this could be an OS problem because I freshly installed Tiger (using my MDD) on a firewire drive, put it on the laptop and still... same Kernel panic, same time in the boot process.
     
  4. macrumors 68020

    zen.state

    Joined:
    Mar 13, 2005
    #4
    Sounds like it could be an extension issue. Make a new bare bones Admin account and if it boots fine then I am 99% sure it's an extension something 3rd party added that has become corrupted.

    Could also be something like the sound controller or something along that line. If thats the case then the KP would be because the extension can't access the hardware it controls.
     
  5. thread starter Guest

    Joined:
    May 12, 2011
    #5
    Thats what I first thought... But how do you explain it won't boot from a clean install?
     
  6. macrumors 68020

    zen.state

    Joined:
    Mar 13, 2005
    #6
    Read the 2nd line I added after your quote. It's possible that one of the controllers on the logic board is dead. It's certainly not a power issue.
     
  7. thread starter Guest

    Joined:
    May 12, 2011
    #7
    Ah... sorry. I read too fast.

    What can I do if one of the controllers on the logic board is dead?
    Does that bascially mean my computer is dead?...
     
  8. macrumors 68020

    zen.state

    Joined:
    Mar 13, 2005
    #8
    First you should run a proper hardware test on it. Do you have the original test disk? I have images of every test disk ever made if you need it. As a certified tech I can legally give them away.
     
  9. thread starter Guest

    Joined:
    May 12, 2011
    #9
    Thanks but the Apple Hardware test is already running. I have all original DVDs. Yesterday I run the "fast test" and it passed everything. I'm running the other one now.
     
  10. macrumors 68020

    zen.state

    Joined:
    Mar 13, 2005
    #10
    If the hardware test finds nothing then you will have to try removing each extension one by one and attempt a boot to really narrow it down. It will be grueling but should find the issue.

    If you have to do the above mentioned then create a temp folder outside of the user folder to hold each one as you try to boot without it.
     
  11. thread starter Guest

    Joined:
    May 12, 2011
    #11
    The hardware test found nothing.

    So... whats happening? One of the hardware components is dead and I gotta turn off the corresponding extension?
     
  12. macrumors 68020

    zen.state

    Joined:
    Mar 13, 2005
    #12
    If a new account didn't work and since the hardware test found nothing along with it booting fine in safe mode tells me it's an issue with one of the less important controllers and/or the PCB connection to it.

    Since I can't put my hands on it the best I can advise is a militaristic hunt for the extension that can't load.
     
  13. macrumors 68020

    zen.state

    Joined:
    Mar 13, 2005
    #13
    Almost forgot.. check the console on both the internal and external installs and see if any errors were posted there.
     
  14. thread starter Guest

    Joined:
    May 12, 2011
    #14
    The damn thing wont even boot in safe mode anymore.
    Plus, it seems to crash when in target mode. I can't mount it on my MDD...

    WTF???
     
  15. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #15
    It seems that graphics card was giving up the ghost and now it's fully dead.
     
  16. macrumors 68020

    zen.state

    Joined:
    Mar 13, 2005
    #16
    I mostly ruled that out since the GPU seemed fine in safe mode. Could also be the video memory.
     
  17. thread starter Guest

    Joined:
    May 12, 2011
    #17
    Anything I can do???....
     
  18. thread starter Guest

    Joined:
    May 12, 2011
    #18
    Update: it boots on the install DVD.
     
  19. macrumors regular

    Joined:
    Sep 19, 2010
    #19
    I know you've run hardware tests and not found any apparent problems but if you ask me, the hard disc has gone south on you - possibly backed up by the fact you can boot it off the optical but a clean install off the HDD was giving you issues.

    As zen.state suggested pulling individual hardware components out and running a trial and error approach might be your only solution now, but the HDD would be my first port of call, and it's a fairly straight forward process to access it on a 1.67 G4. I mean I could be wrong of course, but it certainly wouldn't hurt to just try a known working drive in there.
     
  20. macrumors 68020

    zen.state

    Joined:
    Mar 13, 2005
    #20
    Any updates, Nova?

    I wasn't talking about pulling any hardware as most of it can't be pulled without making the computer unable to boot. I meant disabling it by not loading the extension. Doing that one at a time without a safe boot to see if one not being there allows it to boot without a KP. If it did boot with one disabled then that points the finger at whatever hardware it controls.

    Based on the info I have I would rule out GPU or HD failure at this point at least.
     
  21. thread starter Guest

    Joined:
    May 12, 2011
    #21
    Update: Now it won't boot, even in safe mode. Clean install did nothing. Target mode doesn't work.
     
  22. macrumors 68000

    Nameci

    Joined:
    Oct 29, 2010
    Location:
    The Philippines...
    #22
    Can you still hear the boot chime?
     
  23. thread starter Guest

    Joined:
    May 12, 2011
    #23
    Yes, its just that kernel panic happens earlier now. Apple logo, loading, and kernel panic... It won't make it to the users selection box now.
     
  24. macrumors 68000

    Nameci

    Joined:
    Oct 29, 2010
    Location:
    The Philippines...
    #24
    Even with booting from the install disk? If booting from the install disk boot take to install process without KP, then I am afraid that your HDD is about to give up.
     
  25. thread starter Guest

    Joined:
    May 12, 2011
    #25
    The install process was 100% fine, but when it restarts on the clean install... same kernel panic.
     

Share This Page