PowerBook G4 disc stuck!!

Discussion in 'PowerPC Macs' started by iOneTwo, Jul 21, 2011.

  1. iOneTwo, Jul 21, 2011
    Last edited: Jul 21, 2011

    macrumors newbie

    Joined:
    Jul 21, 2011
    #1
    Hello everybody,

    my friend has tried to install windows or something else i dont know what he do with this powerbook but when I boot the powerbook he told me a foldericon and a question icon, a false windows xp cd is in the superdrive and now I cannot eject the disc. I need to eject the cd then can I install Mac os or something else you know..

    How can I manually eject the cd?

    PS: sorry for my bad english :(
     
  2. thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #2
    Sorry for double post but I've news.

    I tried with Open Firmware (Command + Option OF)

    And now I type "eject cd", but he need a password?

    Now I research and find that I must do this Command + Option PR to reset the password. But it doesn't work. Any idea?
     
  3. macrumors regular

    Joined:
    Aug 9, 2009
    #3
    1. Can you boot the computer into safe mode? (hold down command+s as it starts)?
    2. If so, you should be able to change the root password (instructions should be easy to find) and then use the command drutil eject.

    Otherwise, if you have another mac handy, you could try installing OS X on an external drive, booting from that, and then ejecting the disk.
     
  4. thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #4
    First thnx for help.

    I tried the first one but it doesn't work. This idea with installing OS X on an external drive I also had, but how big is OS X, I only have an USB..
     
  5. macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #5
    To force the cd to be ejected, turn off the Powerbook. Press and hold the trackpad button then turn it on. The cd should eject.
     
  6. thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #6
    Doesn't work :(. Thnx everybody for help, any idea what to do now.
     
  7. macrumors newbie

    j-mods

    Joined:
    Feb 16, 2011
    Location:
    Uinted Kingdom
    #7
    Hi

    If you can't eject it with software, the only other option is to take the powerbook apart and open up the disk drive to remove it

    Julian
     
  8. macrumors regular

    Joined:
    Aug 9, 2009
    #8
    I believe you could install mac OS X on an 8gb flash drive, and maybe on a 4gb one.
     
  9. thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #9
    Thnx, everyone for help. I tried all what I found in my research nothing had worked. Now I'll put Leopard in my friends external drive.

    Best regards, iOneTwo.
     
  10. macrumors 6502

    Joined:
    Feb 26, 2006
    #10
    It sounds ridiculous, but if you hold down the eject button when booting the powerbook that should pop the disc out. The other equally ridiculous method is to keep pressing eject whilst the powerbook boots from being completely off.

    I say it sounds ridiculous, but I've done that on a few different machines, and it seems to work when the disc is stuck.

    You could also try putting the laptop into target disk mode, holding the letter 't' down on boot. When you see the firewire logo on screen, you can attach it to another mac via firewire cable and reinstall the mac os that way.

    Good luck!
     

Share This Page