PowerBook G4 doesn't start up (continues to check the combo drive)

Discussion in 'PowerPC Macs' started by micjan, Aug 22, 2012.

  1. macrumors newbie

    Joined:
    Jul 23, 2002
    Location:
    Belgium
    #1
    Hello,

    I own a PowerBook G4, 1,67 and today it wouldn't start up:
    Powers on, gongs, checks combo drive, checks combo drive again and again, no flickering or lighting on screen, that's all.
    And, sadly, I can't start up in target mode from my external disk (with a bootable backup on it) because the start up behavior in this mode is the same.
    Does someone know what's happening here?

    Thanks on beforehand for a reply

    Jan
     
  2. macrumors member

    Joined:
    Jul 21, 2011
    #2
    have you tinkered with this mac? have you replaced the HD?
     
  3. macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #3
    Have you tried resetting the PRAM? Have you tried removing the optical drive? What does it do if you put a bootable disc in the optical drive?
     
  4. thread starter macrumors newbie

    Joined:
    Jul 23, 2002
    Location:
    Belgium
    #4
    hey, resetting the pram doesn't work. And I can't put a bootable disk in the computer when he is off, isn't it? Removing the optical drive is indeed the next step I want to do.
    I'll feel reassured if it would only be the optical drive that's defective.
    Thanks for your reply!

    Jan
     
  5. macrumors member

    Joined:
    Jul 21, 2011
    #5
    If you have replaced the HD be aware that the 1.67 requires a specific cable: with cables from previuos versions the symptoms are exactly what you describe.
    BTW - does it boot off the OS X Cd/Dvd?
     
  6. thread starter macrumors newbie

    Joined:
    Jul 23, 2002
    Location:
    Belgium
    #6
    I can't put a CD/DVD in the drive if the computer is off.
    I didn't replace the HD.
    A friend of mine is checking the optical drive now. I'm curious about it ... I hope the problem stops there.
     
  7. thread starter macrumors newbie

    Joined:
    Jul 23, 2002
    Location:
    Belgium
    #7
    The motherboard was defective. They put the hard disk in a second hand PB17" and I can reach my documents again. End of story.
     

Share This Page