Powerbook G4 dying? Please help!

Discussion in 'PowerPC Macs' started by Fallinangel, Nov 27, 2006.

  1. macrumors regular

    Fallinangel

    Joined:
    Dec 21, 2005
    #1
    Hello,

    while playing World Of Warcraft today, the display of my Powerbook G4 15" suddenly crashed or something like that!

    Take a look at this screenshot:

    [​IMG]

    Click on the link below for an even more detailled screengrab!
    http://www.monkeydominion.com/files/screencrash_big.jpg

    It seems as if the game causes this weird behaviour of the screen, because after restarting and performing normal tasks, some office and some internet surfing, even playing Quake III Arena, nothing happened!
    However after visiting YouTube and reinstalling WOW it crashed again (during the installation process)!

    Furthermore, OS X does not report any errors!

    I'm currently using a 15" Powerbook G4, with a 1.25 GHz CPU, 512 MB RAM, and an ATI Mobility Radeon 9600 graphics card!

    Any ideas or suggestions? Does anybody know this problem and maybe a solution?

    Thanks in advance for your help!

    Fallin_angel :(
     
  2. macrumors 65816

    Joined:
    Jul 28, 2004
    Location:
    Portland, Oregon
    #2
    So it looks like a WOW problem if everything else works OK including Quake which would give the system a pretty good workout. 512MB doesn't sound like a lot of RAM though it fits the minimum spec
     
  3. macrumors 603

    2nyRiggz

    Joined:
    Aug 20, 2005
    Location:
    Thank you Jah...I'm so Blessed
    #3
    Its the game....get rid of it and see if it fixes the problem.


    Bless
     

Share This Page