Powerbook G4 Perpetual Sleep

Discussion in 'PowerPC Macs' started by clarkjus93, Feb 3, 2011.

  1. macrumors newbie

    I'm new here, migrated from mac-forums.com. They never have any good answers.

    So, I bought a 17" PB G4 from eBay for a good price. The only advertised thing wrong with it is that the screen has two lines on it, I was eventually going to replace the screen.

    Anyhow, I got the computer almost 2 weeks ago and the guy had sent me the wrong power adapter (a 45w instead of a 65), so I had to wait to send him back the 45 and get myself a 65. I figured this out because about 5 minutes after I started up the computer, it went to sleep and wouldn't wake up. I figured at the time is was because it wasn't getting enough power to charge the nearly dead battery.

    The 65w arrived today. I first plugged in the computer, and powered it up, it chimed and all came on. I spent like half an hour configuring it and setting it up, then I closed the lid to put it to sleep. Everything went dark as usual and the little light came on. About 15 minutes later I tried waking it up and it wouldn't wake up at all.... i pressed a bunch of keys, the power button, opened and closed the lid...nothing.

    I should note that although I was using the computer, it said that there was only 1% battery life and it wasn't recognizing that it was plugged in. A message popped up telling me it was going to sleep if I didn't plug it in, but I used it for almost 5 minutes after that. I wasn't concerned with this; I assumed it related to the nearly depleted battery, and that it would fix itself after a good charging.

    I should also note that the 45w charger that the seller sent seemed to have failed after plugging it into the computer. It got really hot and buzzed. The same thing is happening to my 65w charger. Is it possible that the PB is causing a failure of ac adapters?

    Things i have tried thus far:

    Taking out the battery (the light stayed on)
    Pressing the power button for 5 seconds
    Resetting the PMU

    So what is wrong with it? Is it the PMU/logic board? the battery inside that controls the clock...etc? The DC in board? Or is the battery just so old that it screws with the computer.

    Thanks for any and all input. Sorry for the length!

  2. TEG
    macrumors 604


    It is likely an issue with the DC/DC Board. I would see if you can find someone locally with whom you can swap batteries to test, or try the Apple Store (or authorized repair center). It shouldn't be a big deal to fix.

  3. macrumors newbie

    Does the Apple store deal with Powerbook G4s? This one is from about 2005, it's one of the last-gen ones.

    And if it is in fact the DC board, why does the computer go to sleep and never wake up? It doesn't fall asleep by itself, I put it asleep, but I couldn't wake it up.

    I think I can do the Dc board repair myself, actually. I have some experience opening up these machines.


  4. TEG
    macrumors 604


    The Apple Store usually has equipment available to test these older machines. When power issues occur, they behave sporadically.

  5. macrumors newbie

    Oh, the only reason I ask is because I once had the Apple store refuse to look at my 1.25 ghz PB. They said it was too old.
  6. macrumors 6502a

  7. macrumors 6502

    Same problem on the PB 17" that I inherited. Check out the DC/DC board, and all looked good. When I put it back together, it would go to orange for a few minutes and back to green. I still haven't gotten around to it yet, but I'm going to eventually buy a new one of those boards.

Share This Page