Powerbook G4 problems - someone please help

Discussion in 'PowerPC Macs' started by rakester, Sep 7, 2008.

  1. rakester, Sep 7, 2008
    Last edited: Dec 16, 2013

    macrumors member

    Joined:
    May 18, 2008
    #1
    ////
     
  2. rakester, Sep 7, 2008
    Last edited: Dec 16, 2013

    thread starter macrumors member

    Joined:
    May 18, 2008
    #2
    ////
     
  3. macrumors 68000

    iToaster

    Joined:
    May 3, 2007
    Location:
    In front of my MacBook Pro
    #3
    It's not the hard drive, it's more likely to be that you're running Leopard on 512 MB or RAM, which needs more RAM. Of course, there could be a deeper problem, such as bad RAM in general, but not having enough RAM will produce a lot of slowdowns and potentially lockups, but, once again, I can't rule out some other problem in this situation. The beep(s) would indicate bad RAM, so I'd have to go with the RAM... potentially both slots are actually failing... I dunno...
     
  4. macrumors 6502

    Joined:
    Aug 20, 2007
    Location:
    Houston, TX
    #4
    try running memtest for a couple of hours
    http://www.memtestosx.org/
    see if you get any errors, the program costs 1.39, but could easily answer your problem
     
  5. macrumors 6502a

    JPIndustrie

    Joined:
    Mar 12, 2008
    Location:
    Queens, NY
    #5
    I think you can get another 512 for pretty cheap nowadays. It's not like it's 2003 :p

    Try getting another 512 to replace the you had.
     
  6. rakester, Sep 8, 2008
    Last edited: Dec 16, 2013

    thread starter macrumors member

    Joined:
    May 18, 2008
    #6
    ///
     
  7. rakester, Sep 9, 2008
    Last edited: Dec 16, 2013

    thread starter macrumors member

    Joined:
    May 18, 2008
    #7
    ////
     
  8. macrumors 6502a

    g4cubed

    Joined:
    Jun 2, 2004
    #8
    It could be but my vote is to get more RAM especially since you're running Leopard.
     
  9. macrumors 601

    andiwm2003

    Joined:
    Mar 29, 2004
    Location:
    Boston, MA
    #9
    the powerbooks of that time had a problem called upper ram slot failure.

    the ram slot failed, not the ram itself. try putting your ram in the other slot and see if it's better. if it is better go to a apple store, maybe it's under warranty (mine was).

    aside of that replace your ram with at least a 1GB stick.
     
  10. macrumors 6502a

    jalagl

    Joined:
    Jun 5, 2003
    Location:
    Costa Rica
    #10
    Those Powerbooks in particular suffered from several issues that became apparent after the warranty expired. Mine had the following issues:

    1. First, it would go to sleep every once in a while while you were working. it was frustrating to say the least. It turns out one of the temperature sensors (under the trackpad) tends to go bad, so the PB goes to sleep because of an "overtemp" signal. This can be "fixed' by removing some kext files that deal with the temperature sensors.
    2. Then, I had the same issue with the memory. The memory slot failed, and the computer had the same symptoms as yours. This is well-known issue, and Apple even had a replacement program for a while. The only definitive fix is to replace the motherboard, and, if it isn't under warranty, can get very expensive.

    There is some information and links over at Wikipedia
     

Share This Page