1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

PowerBook G4 - strange startup / optical drive issue

Discussion in 'PowerPC Macs' started by iMark Nano, Oct 8, 2010.

  1. macrumors newbie

    Hi everyone,

    I have a problem with my PowerBook G4 that I'm really hoping some cleaver soul on here can help me with. I will bullet point everything so it's easy to digest!

    • A CD got stuck in my optical drive (mechanism failed) so I bought an official Apple, fully compatible optical drive to replace it

    • I fitted it, made sure everything was connected fine before I put it back together again

    • Now when I start the machine up, it hangs for aaaaaaages on the grey Apple screen, with the 'loading rotating grey circle thing, as if it's attempting to load). If I leave it long enough (about 15 mins) it will get the the blue screen (that appears just before it loads the desktop) and then sometimes it reaches the desktop but this is rare. If it does, it's extremely unresponsive, with any mouse clicks registering about 45 seconds after I click something.

    I've tried to reset the PMU but I don't know what else I can do - there's nothing I can think of doing that would help. How come this optical drive has caused a severe crash such as this?

    Thanks in advance for any help you can give!

  2. macrumors 6502a


    As a troubleshooting step, you may want to unplug the new optical drive (should have the opening steps down by now, I'm sure!).

    The drive is probably conflicting with the other hardware (or something broke in the transplant).

    I would start by unplugging the drive and seeing if it boots like that. If it does, check all the drive connections (jumpers on this?) and try again.

    Apple notebooks are so easy to open, shouldn't take but a few days to figure this out...


    I guess there are jumper pins on the drive, but they should all be empty (I seem to remember this from operating on my old iBook G4).

    You could try these steps-

    reset PMU

    reset PRAM

    boot to open firmware (hold command-option-o-f at boot) and type "reset-nvram" (without quotes) enter, the type "set-default" enter, then type "reset-all" enter

    Then, if that doesn't work - when if finally does boot up ever so slowly, is the drive recognized in system profiler?
  3. macrumors newbie

    Thanks for your reply!

    I'll take the optical drive out and see if it boots fine without. I do know that the only time the startup made it to the desktop, the system profiler did recognise the HD, so I'm fairly confident it has something to do with this new optical drive I bought not the HD.

    Even though it's very similar, do you think that I would need to buy the EXACT part number optical drive for this PowerBook model? I don't think the part numbers match you see. Could it be that it's just not fully compatible or buggy?
  4. macrumors 6502

    No, you shouldn't need to buy the exact model. For example, I bought a Pioneer DVR-K05 to fit in a Powerbook G4 Titanium and it worked just fine in it. It does sound like the drive may be broken so you may want to send it back.

    As another step, could you boot holding down Command (Apple key)+V as soon as you hit the power button? That will bring up the Verbose text boot log. Take a look and see if anything glaring stands out. Maybe get a camera phone screen shot if you can. There's probably something there that may shed some light on this issue.
  5. macrumors newbie

    Just an update for those who may have a similar problem. I took the drive out and it booted fine with no problems without it.

    I then installed a new optical drive (which happened to have the exact model number as the original one it shipped with) and it booted up fine too!!

    That means a) Faulty optical drive or
    b) Compatibility issue between that particular model number of drive with my PowerBook.

    Thanks to those who tried to help!

    EDIT: Here is a screenshot of the Verbose text log when it STILL had the 'faulty' drive in:
  6. macrumors 6502a


    Glad you got it working with a different drive.


Share This Page