Powerbook G4 with no solution?

Discussion in 'PowerPC Macs' started by mooesmoo, Oct 26, 2010.

  1. macrumors newbie

    Oct 26, 2010
    Hi everyone.

    Some days ago i finally added a Powerbook g4 to my Mac collection and since then ive been trying to fix this computer without any results.

    The Powerbook had the battery dead at first and i had to replace it with a new one i had. Now the problem/weird thing is that the computer detects the battery but it doesnt charge.

    It has about 18% of the charge and when i try to boot up all i hear is like a fan sound and nothing more, no boot up sound and no image on the screen.

    If i boot up using the power cable thats when i see the 18% of the battery icon, but as soon as i take out the power cord, the image goes black although the computer still makes sounds as if it was on.

    Does it have any solution?

    PS: ive tried to reset the PMU,changed the pRam for a new one, reset the Nvram.

    Thanks in advance.
  2. macrumors 68040


    Dec 7, 2009
    Which exactly PB it is? Did you try another charger? How about charger's light? Does it change its color (green - no charging, orange - charging)? If charger is OK, bad DC-in board could be source of your problem.
  3. thread starter macrumors newbie

    Oct 26, 2010
    I fixed the problem with the computer not detecting the power from the battery ( had to desolder a resistor on the logic board).

    The problem is still with the cable. The light is always orange and doesnt change.


    PS: its a PB 1.67ghz DL
  4. macrumors newbie

    Dec 27, 2012
    Hello, Mooesmoo,

    Do you still remember which resistor you desoldered? My boy's hand me down 15" G4 1,67 GHz DL PowerBook won't charge nor run from its battery yet the computer does recognize the battery via system profiler and coconut.. In the menu bar it states "not charging" (actually the equivalent in dutch).




Share This Page