Powerbook g4 won't boot into any mode

Discussion in 'PowerPC Macs' started by iron chique, Jan 1, 2011.

  1. macrumors newbie

    Joined:
    Jan 1, 2011
    #1
    My trusty ol' powerbook might have finally met its match.

    I can not get it to boot into any mode.

    I've tried booting to the original discs ('C' while starting up); safe mode, single user mode, etc....
    I've reset the PMRAM (or whatever it's called), still no luck

    It seems perma stuck at the blue screen.

    Any thoughts?
     
  2. macrumors member

    Joined:
    Jul 16, 2009
    #2
    Not good.

    I'd try removing the battery and letting it sit for a few days. Another thing i would try is a Firewire optical drive if you have one...just in case the internal drive is bad.

    Maybe remove/replace the PRAM battery, it might be bad.
     
  3. thread starter macrumors newbie

    Joined:
    Jan 1, 2011
    #3
    Which firewire cable would I need to hook it up to my macbook 2.4 (early '08)?
    And how do I remove the PRAM batt?
     
  4. macrumors member

    Joined:
    Jul 16, 2009
    #4
    You would need a Firewire 400 to 800 cable to connect your PB to your Macbook (assuming your macbook has firewire). eBay has them for about $5 shipped.

    To remove the PRAM battery I would just google 'Powerbook G4 PRAM battery removal' and whatever model it is (i.e. Titanium or Aluminum).
     
  5. thread starter macrumors newbie

    Joined:
    Jan 1, 2011
    #5
    Is that a 6pin to 9pin?

    thanks for your help!
     

Share This Page