1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

powerbook g4, won't work

Discussion in 'PowerPC Macs' started by MYMACISHURTIN, Jun 24, 2007.

  1. macrumors newbie

    #1
    i can hear it starting up and clicking around in the inside of the computer but it won't start. it's in pretty good condition and it's used for work. i need this laptop, what could have happened?
    could it have been when someone used the laptop they were under a blanket and put the laptop on their knees with the blanket and their P-J's covering it? thats what someone was doing with it and it was working.
    i tried switching the brightness on the screen.

    thanks for the help :apple: :apple:
     
  2. Moderator emeritus

    mkrishnan

    #2
    Your notebook was inside their pants? I'm confused.

    Be more specific, please (and try to use proper grammar). When you say it does not start, what exactly does happen? Does the screen light up at all? Do you see the grey screen with the Apple logo? Do you hear the startup chime (sounds like a loud "bong" sound)? Does it get farther than this?

    If it doesn't even get to the grey screen, try holding down cmd-opt-p-r during reboot and see if that helps.
     
  3. macrumors newbie

    #3
    =]

    No, it wasn't in their pants; Haha.
    When I press the button to start it i hear the noises as if it were starting, the screen doesn't light up at all, no chime.
    Well, i would press cmd-opt-p-r but I don't know what those are. Explain please?
     
  4. macrumors G4

    Chundles

    #4
    Start up the computer holding down command-option-p-r until you hear the chime twice.
     
  5. macrumors newbie

    #5
    Is the command button by any chance the key with the :apple: on it?

    Are p and r just the P and R keys?
     
  6. Moderator emeritus

    mkrishnan

    #6
    Yes, Command is the one with the apple on it, Option is the one to the left of it (that probably says Option), and P and R are the letters of the Roman alphabet that are on your keyboard. ;)

    Press the power button, immediately press and hold Command and Option first, then hold P and R -- hold all four buttons (Cmd, Opt, P, R) down until you hear the startup chime twice, if you hear it (it takes several seconds).
     
  7. macrumors newbie

    #7
    I just held down opt-p-r and the power button (Not sure if that's what I was told to do..) and the computer started and I heard the fans blowing and everything, didn't start the screen but I heard a long BEEEEPPP and then the loud fans stopped.
     
  8. Moderator emeritus

    mkrishnan

    #8
    Read my post directly above yours.
     
  9. macrumors G4

    Chundles

    #9
    Why didn't you do what we told you to do?
     
  10. macrumors newbie

    #10
    Just did what you told me except holding all of them before it started, the screen flashed for a sec and the light turned on where you press the button to open the laptop. I then heard a beep.
     
  11. Moderator emeritus

    mkrishnan

    #11
    You're making my brain hurt, but I'll try for a couple more minutes. What happened *AFTER* that? You didn't let go of the buttons, did you? Did it continue to boot, or did you have to shut it off by holding down the power button?

    If the latter, the next two options:

    1) Find the system install / restore DVD or CD #1, put it in the drive, press the power button, and hold the "C" key to boot off the disk.

    2) Press the power button to turn it on and then press and hold option-S. You should boot to a text prompt. At the top, it will tell you that you can use this command to fix the drive:

    /sbin/fsck -fy

    You type that in exactly like that (It'll be on the screen for you to see) and then press enter. Post back what the final result is. If it says that it's successful, try typing in:

    shutdown -r now
     
  12. macrumors newbie

    #12
    Nothing happened after the beep, all the fans stopped and it was just like before.

    I don't have the system install or restore dvd, this is a college loaner but i'll try opt-s.

    Be right back.
     
  13. macrumors newbie

    #13
    Nothing happened. I need help!
     
  14. Moderator emeritus

    mkrishnan

    #14
    If you never got to the text prompt, and if the screen never even lights up, it might be something more serious... Sorry....
     
  15. macrumors 603

    gauchogolfer

    #15
    Opt-c tells it to boot from the disc, rather than the HD. So, if you don't have a system disc, obviously that won't help.

    I think your only option at this point is to try booting from the install disc.

    It sounds to me like a major hardware error, if you can't even boot into single-user mode. (That's what the opt-s was for.)
     
  16. macrumors newbie

    #16
    Well don't I need the CD 1?
     
  17. macrumors newbie

    #17
    THANK YOU ALL SO MUCH!

    I tried opt-s when turning it on and it worked!!
    Thanks so much!

    I hopefully won't be back! (Or won't need to be! =] )
     
  18. Moderator emeritus

    mkrishnan

    #18
    Riiiight. Well, I'm glad you got it working. Have fun, kid. :)
     

Share This Page