PowerBook "Hardware" System Preference

Discussion in 'Macintosh Computers' started by SoulBlighter, Jun 10, 2004.

  1. SoulBlighter macrumors newbie

    Joined:
    Apr 5, 2004
    #1
    I have been looking many places to find an answer, but to no avail; and was wondering if someone here could provide some insight into my dilema. I was curious... I have the "Hardware" System Preference Pane for my PowerBook 17" 1.5 Ghz- as we all do, I am sure, but why is my "L2 Cache" an option? It is a list of two selectable options- None or 512KB. None had been selected as default so I tried setting it up to its 512KB, seems to make sence. All seems good. I quit System Preferences, open the "Hardware" pane, and again, the "L2 Cache" is reset to 'None'. Why does it do that?

    Also, if I try to enable "Show control in menu bar"- that option automatically disables (uncheckes itself) after a few moments. If I do manage to make it stick, it to resets when I quit and reselect the pane.

    In adition to that, does the clickable CPU to the left mean anything? Theres no apparent feedback, just empty clickieness.

    So, why do I have a choice in "L2 Cache"? (higher seems preferable)
    And why does it reset?
    And whats the point of being able to click that CPU icon to the left?

    I remember it had done that same exact thing for by brother's laptops in the past (Ti800 and an Al 17" 1.33)
    I thank you very much and any information about this 'puzzle' would be most appreciated!
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    You have installed the CHUD tools. This preference is to help developers test their Apps performance. If you have a dual processor machine you would be able to turn off one of the CPUs as well.
     
  3. steadyeddie macrumors member

    Joined:
    Oct 24, 2003
    #3
    Just adding to robbieduncans's reply: the reason the cache setting keeps resetting itself is probably that the version of CHUD you have is too old for your model of Powerbook. I found this happened on my 12" until I updated to the newest version of CHUD.
     
  4. SpaceMagic macrumors 68000

    SpaceMagic

    Joined:
    Oct 26, 2003
    Location:
    Cardiff, Wales
    #4
    It's seriously not good to have L2 Cache off. It would make your PowerBook feel horrible! Especially after you forking out so much money for that machine.

    However, it could just be a bug in the system preferences. Do this:

    Click your apple menu (top left)

    Click 'About this Mac' - You should now be looking at a small window with your MAC OS X details.

    Click 'More Info...'

    System Profiler should have loaded. It should be default 'Hardware'. If not click on Hardware - it's at the top of the left hand list column.

    In the information on now on the right... it will say 'L2 Cache (per CPU):

    This will tell you if the system preference resetting to zero thing is a bug or not. If it says 0KB here or None (I don't know what it'll say, because i've never turned it off) then download the latest CHUD like a previous poster said.


    Sorry if this thread is patronising, I am writing it for people who may have the same problem as you, just not as Mac literate.
     
  5. SoulBlighter thread starter macrumors newbie

    Joined:
    Apr 5, 2004
    #5
    Hello again.

    Just wanted to thank you all for your help. And SpaceMagic, it wasn't at all patronising, I can understand your reasoning.

    I downloaded the latest CHUD update and now everything is now running up to par just as it should be in the System Preference "hardware" pane. I once again have that 'control' over those options. Thank you once again.
     

Share This Page