PowerBook issues - Battery and Sleep Mode

Discussion in 'PowerPC Macs' started by Love, Jun 29, 2008.

  1. macrumors 68000

    Love

    Joined:
    Jan 20, 2007
    Location:
    Just southeast of Northwestshire
    #1
    I have two problems with my PowerBook G4. It's a 1.5 GHz 15 inch model running 10.5.3.

    1. This problem gradually got worse - whenever I woke from sleep, it would freeze for 15 seconds to 30 seconds. Now, it's gotten to the point where it won't come out of a constant beachball whenever I open the machine. This is combined with general sluggishness and unresponsiveness during all use of the computer.

    2. The battery - sometimes it will randomly die and the machine will go to sleep mode. Sometimes it could be as high as 70% where it shows 70% then in a fraction of a second it goes to zero. The light on the battery shows the same - one second it could be at 4 lights, then one blinking one the next.


    I'm not sure if I need a new battery or what is wrong with this machine. I've tried a PRAM reset and various other common things like that.
     
  2. macrumors 68020

    Dmac77

    Joined:
    Jan 2, 2008
    Location:
    Michigan
    #2
    I can't help with the general sluggishness of the computer, but I recently bought a "new" iBook and the battery would say it had a 85% charge, and then all the sudden the computer would die. It turned out that the battery on your computer needed to be replaced, once I replaced the battery the battery issue was gone. Hope this helps, sorry I couldn't help more!

    Don
     
  3. thread starter macrumors 68000

    Love

    Joined:
    Jan 20, 2007
    Location:
    Just southeast of Northwestshire
  4. macrumors 68020

    Dmac77

    Joined:
    Jan 2, 2008
    Location:
    Michigan
  5. thread starter macrumors 68000

    Love

    Joined:
    Jan 20, 2007
    Location:
    Just southeast of Northwestshire
    #5
    I solved the Sleeping issue - I formatted and installed a new copy of Leopard. Now it's only a moment before it works. :)
     
  6. thread starter macrumors 68000

    Love

    Joined:
    Jan 20, 2007
    Location:
    Just southeast of Northwestshire
    #6
    It's back. I updated to 10.5.4. I was reading the Wikipedia article on the MacBook Pro problems section, and although this is a PowerBook, i am experiencing this issue, except it's just when I wake from sleep:

    -A small number of users have experienced issues with an unresponsive GUI, which can only be remedied by a reboot. Symptoms include: The mouse pointer can still be moved, iTunes still does play, and it is possible to log in with SSH.

    As a LOLCat would say: HALP
     

Share This Page