Powerbook Logic board advice & help

Discussion in 'PowerPC Macs' started by OrangeSVTguy, May 7, 2008.

  1. macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #1
    Hey I'm looking to get this titanium powerbook but it has a broken screen, possibly bad backlight? I can get it for a good price and I would love to have it to replace my ibook. I don't know the specs for sure but I am positive I think it's the DVI version since it has the keyboard that looks like the ibooks(same placement for the keyboard release latches).

    The guy said it worked fine on an external monitor but just recently he said it won't boot now and it now makes a high-pitched whining sound. Anyone know what that is? I'd like to use it as a headless mac until I locate a new screen for it.

    So I'm just wanting to get the advice if it's something major or something minor as I've never had a PB before.

    Thanks :apple:
     
  2. thread starter macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #2
    So anyone know what the problem could be? Faulty DC in board or optical drive keeping it from booting up? I think I'm gonna buy it anyways and just tinker around with it :D. Who knows, maybe I'll get lucky ;)
     
  3. macrumors member

    Joined:
    Oct 11, 2007
    #3
    What are the specs? My mom has a Ti-book that she's run for years, but I've got to say it's getting a little long in the tooth...
     
  4. thread starter macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #4
  5. thread starter macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #5
    Ok I picked it up this morning. It's a 550mhz gigabit ethernet model. It has 512mb memory (2x256mb) 20gb hdd and a DVD-rom.

    I guess the logic board is shot because it doesn't have separate DC in board like the later models and it's emitting a high pitched buzzing sound when I press the power button and it won't boot.

    The buzzing is actually come from this part in the circled area in the picture.

    I think I'll need to buy a screen for it too since the guy said it didn't work. For less the $150 I can get a 667 VGA model logic board and screen for it so I'm thinking of just fixing it...
     

    Attached Files:

Share This Page