Powerbook Memory No Longer Recognized

Discussion in 'PowerPC Macs' started by chancellor, Sep 17, 2005.

  1. macrumors member

    chancellor

    Joined:
    Jul 15, 2003
    Location:
    Edmonton
    #1
    My 1.5 year old Powerbook has two memory so-dimms (each 512 MB). Recently, the lower slot's memory stopped being recognized. I tried reseating the so-dimm and it fixed the problem briefly, but soon stopped recognizing that so-dimm again.

    I then tried swapping the two so-dimms, and while that fixed the problem briefly, eventually the _same_ slot's memory wouldn't be recognized.

    It's clear that the memory itself is not the problem. Is there anything that can be done to fix this, or am I looking at a bad motherboard?

    Also, since I don't have AppleCare, what's the best way to deal with Apple Support (i.e. can I just pay for the repair without paying for a tech support incident file)?

    Thanks for your help!
     
  2. macrumors P6

    wdlove

    Joined:
    Oct 20, 2002
    #2
    You should give Apple a call and see what they say. Maybe they would just allow you to send it in to them. You could also try a local reseller.
     

Share This Page