Powerbook not recognizing iPhone 3.0/iPod 3.0 after updating to iTunes

Discussion in 'iOS Programming' started by wiscal, May 15, 2009.

  1. macrumors newbie

    May 15, 2009
    Bit of a unique situation.

    Have MacMini with 3.0 sdk, iTunes and iPhone and iTouch with 3.0 installed as well. Everything there works harmoniously.

    Also have a pc running latest iTunes. Harmony as well between all devices.

    Here's where it gets complicated: I have a Powerbook G4. Seeing as I can't run the sdk on this set up I dragged the .dmg files over for the new iTunes and iPhone (same way I got this on my pc). I updated iTunes to From that point forward that computer no longer recognizes either the iPhone or the iTouch when plugged in. They don't even charge.

    What happened? How can I fix it?

    (One possible related issue, not sure: When intending to install iTunes on my G4 I accidentally ran the iPhone 3.0 .dmg. The open animation ran but nothing happened after that.)

    Hints? Tips? Suggestions?

    Very much appreciated - Wiscal.
  2. thread starter macrumors newbie

    May 15, 2009
    Considering un/re-installing iTunes

    This is a last resort so I'm putting out another call for assistance before I take this step.

    Is there any info out there as to why my powerbook G4 is no longer recognizing my iPhone (w/ 3.0) and my iPod touch (w/ 3.0) even after upgrading iTunes to 8.2? The devices won't even charge when plugged in - no recognition at all.

  3. macrumors 65816

    May 21, 2009
    do they charge in the wall?

    im not sure, but never overlook a faulty usb cord or even usb port on the machine. granted that could very well not be the issue.

    or do they still work with the pcs? im not clear on what you've said...
    that would certainly be a bit ironic.
  4. macrumors regular


    Jul 12, 2008
    Melbourne, Australia
    Sorry to drag up an old thread....

    But I'm having same issue.

    iTunes will *not* recognize iPod Touch on 3.0 GM *at all*. However, it does charge.

    Very weird...
  5. macrumors newbie

    Jun 11, 2009
    Bay area california
    I think you need a intel chip to run 8.2 and sdk 3.0 but dont quote me if im wrong.
  6. macrumors regular


    Jul 12, 2008
    Melbourne, Australia
    I have the 1st Gen Aluminium iMac, as my signature states.......

    EDIT: I have had 3.0 GM running fine in the past, I have my iPod linked to a friends Dev Account. So it's not an issue with that.

Share This Page