powerbook will not get past blue screen

Discussion in 'PowerPC Macs' started by h0e0h, Oct 20, 2007.

  1. macrumors 6502a

    h0e0h

    Joined:
    Aug 30, 2004
    Location:
    West Monroe, Louisiana
    #1
    After searching and reading this post I hold the shift key to start in safe mode and the 12" pb shuts down. Assuming Sherman is correct my HD is corrupt or for worse dead. Any suggestions on the easiest thing to do for this machine?
     
  2. macrumors regular

    macjack1

    Joined:
    Oct 3, 2007
    Location:
    The Big Apple
    #2
    Repair Disk:

    Steps for using Disk Utility

    1. Insert the Mac OS X Tiger Install disc or Install Disk 1 that came with your computer, then restart the computer while holding the C key.
    2. When your computer finishes starting up from the disc, choose Disk Utility from the Installer menu. (In Mac OS X 10.4 or later, you must select your language first.)
Important: Do not click Continue in the first screen of the Installer. If you do, you must restart from the disc again to access Disk Utility.
    3. Click the First Aid tab.
    4. Click the disclosure triangle to the left of the hard drive icon to display the names of your hard disk volumes and partitions.
    5. Select your Mac OS X volume.
    6. Click Repair.
    If you repair errors run it until no errors found.

    -mj
     
  3. thread starter macrumors 6502a

    h0e0h

    Joined:
    Aug 30, 2004
    Location:
    West Monroe, Louisiana
    #3
    Tiger disk is MIA, Leopard will be here Friday, it should still work eh?
     
  4. macrumors regular

    macjack1

    Joined:
    Oct 3, 2007
    Location:
    The Big Apple
    #4
    Yes, if it works. If not, you may have to use DiskWarrior or TechTool Pro

    If you still have the disks that shipped with your PowerBook you can run Apple Hardware Test.

    If CD's came with your computer it is on a CD labeled "Hardware Test" To test with CD, insert the CD and restart holding the "c" key until you see the spinning gear.

    If DVD insert DVD then:
    1. Turn on or restart the computer.
    2. Immediately press and hold the Option key. After a few seconds, the Startup Manger screen appearsThe Startup Manager scans for available volumes.
    3. Optional: Clicking the circular arrow rescans for other volumes, including NetBoot Server volumes. You can eject any disc in the drive or open an empty tray-loading drive by holding down the Command (Apple) and Period (.) keys. The Command-Period key combination will also close the drive. After inserting a CD capable of starting up your computer, you could rescan for volumes.
    4. Click the startup volume you want to use. "Hardware Test"

    If hardware test does not mount or does not run bring the computer to Authorized Apple Repair.

    -mj
     
  5. thread starter macrumors 6502a

    h0e0h

    Joined:
    Aug 30, 2004
    Location:
    West Monroe, Louisiana
    #5
    The problem is definitely the HD. The error I get when I run the repair disk option under disk utility Invalid B-tree node size / volume check failed. / Error: Filesystem verify or repair failed
    Its almost like the HD doesn't exist because if I go to install Leopard, no where does it give me the opportunity to select HD "The Mac" for an installation location.

    Who knows what's going on. This is my wife's laptop and the only thing that she uses it for is POP3 email and web browsing. She MIGHT type the occasional word doc with it. So what I did was just erase the disk (there was really no data to back up) and now it appears that after the erase Leopard is installing. Very odd that something on the software side was causing it not to boot, I thought perhaps it was a corrupt HD, but after erase it all seems to be fine. I'll let you know how it turns out.
     
  6. macrumors member

    Joined:
    Jan 4, 2005
    #6
    RE: bad HD...

    Could have been a bad sector or sectors on the HD; preferably in the startup data sequence. I had a similar problem a couple of years ago when I used my computer, shut it down for the night, and woke up in the morning and went to boot it up but it wouldn't go past the grey apple logo screen.

    Tried running Disk Utility and DiskWarrior, but neither could repair it, however, I did notice that when I was booted from a CD, I could still access my files on the computer. So, I just backed up those files to a flash drive, and wiped the HD and started over.

    The installer will actually isolate and avoid bad sectors while installing and from that point on it was fine. One could always tried to rebuild the bad sectors, but I was in the market to upgrade to a larger HD anyways, so I just did that, cloned the original HD, and then just made the original a backup drive.
     

Share This Page