powerbook won't startup!

Discussion in 'PowerPC Macs' started by wildernessbob, Oct 5, 2012.

  1. macrumors member

    Joined:
    Oct 24, 2006
    #1
    help!, i have a powerbook g4 1.67 that was working fine last night, but won't startup this morning. it wasn't moved or dropped. when i push the power button i get the tone and the optical drive does it's noise like it's trying to unload a cd, then it just keeps making the noise every 2-3 seconds. the LED sort of dims or blinks at random. so i hold the power button down until it shuts off, then try to start it again, this time i may or may not get the tone. the OD just starts cycling again. i reset the PMU which made the LED shine constantly at least, but didn't seem to change anything else, tried to reset the PRAM, but i don't know if that actually worked. i don't think there have been any symptoms to indicate any trouble, it's been working well every day. so what can i do next?
    WB
     
  2. macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    One of the ram slots may have died. Try starting it with only one ram stick in. Switch between the two slots to see if it boots with the ram in either just the lower or just the upper.
     
  3. macrumors 603

    justperry

    #3
    Seems like it is power cycling every few seconds.

    Wouldn't he hear a few beeps if somethings wrong with the RAM.
    I have the same Powerbook, never encountered this, but also both My Led and lower Ram slot isn't working.
     
  4. thread starter macrumors member

    Joined:
    Oct 24, 2006
    #4
    Thanks guys,
    i tried switching the RAM, but no go. it just keeps cycling the optical drive. the battery seems good for it's age, still runs the thing for about an hour with the AC disconnected, but we've noticed that if we let the bat die and shut down the time and date are all screwed up, but nothing else seems to be amiss.
    wb
     
  5. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #5
  6. thread starter macrumors member

    Joined:
    Oct 24, 2006
    #6
    so, any other opinions before i start to cry?
     
  7. macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #7
    Take the battery out. Sometimes bad batteries totally screw up the whole electrical system. Happened with Titanium Powerbooks.

    Plug it in for a while w/out the battery, reset pram and try again
     

Share This Page