Powermac and WoW quality

Discussion in 'Games' started by eva01, Feb 13, 2007.

  1. eva01 macrumors 601

    eva01

    Joined:
    Feb 22, 2005
    Location:
    Gah! Plymouth
    #1
    Ok so I don't know if this is a hardware issue or a WoW server issue.

    I have a Dual Proc 1.8 G5 with 3GB of RAM and a 6800 Ultra. With the latest OS

    For some reason randomly my FPS will go from the average of 25 down to 6 and stay there for quite some time if i try to do anything in the game except sit there. This *usually* happens in Zangarmarsh, but did happen two days ago in Hellfire.

    Now I am wondering if this is more likely due to my computer hardware or more likely a server issue that caused a sudden nosedive in the FPS.


    Thanks.
     
  2. jenn221 macrumors member

    jenn221

    Joined:
    Feb 4, 2007
    Location:
    Louisiana
    #2
    Sounds like a server issue to me. Have you played WoW on this computer before and had problems? Other macs?

    I play WoW on an iBook G4 and haven't had any major problems like that.
     
  3. eva01 thread starter macrumors 601

    eva01

    Joined:
    Feb 22, 2005
    Location:
    Gah! Plymouth
    #3
    Nope no previous problems, it has happened 2-4 times that i can recall and all in the outlands.
     
  4. TastyCakes macrumors newbie

    Joined:
    May 4, 2006
    #4
    You remember if you minimized earlier and surfed the web for something then came back? There is a known issue with minimizing and it causing a huge memory leak that is slated to be fixed with Leopard.
     
  5. eva01 thread starter macrumors 601

    eva01

    Joined:
    Feb 22, 2005
    Location:
    Gah! Plymouth
    #5
    No i don't minimize it. If i want to surf i just put it in windowed mode.
     

Share This Page