Powermac dual 2.5 blank display

Discussion in 'PowerPC Macs' started by davebquinn, Mar 10, 2010.

  1. macrumors newbie

    Joined:
    Oct 31, 2002
    Location:
    london
    #1
    I would be very thankful for any help on this

    My late 2004 G5 dual 2.5 is misbehaving. It was working fine, I left it in the box before selling a couple of months ago and have decided to keep it now, but when I switch it on it powers up but the display screen is completely blank, black.

    I've tested the hard drive, the ram and the screen, all no change. I have tried to use it as a target drive using firewire to a macpro with no success. I have taken out and refitted the graphics card

    ATI RADEON 9600 XT with 128MB DDR SDRAM,

    same story.

    It starts up and then the fans go a bit mental and I have to switch off.

    I'm stuck, could anyone give me a hand, do I need to replace the graphics card, if so what is an inexpensive option.

    Thanks in advance
     
  2. macrumors 68040

    rickvanr

    Joined:
    Apr 10, 2002
    Location:
    Brockville
    #2
    I might sound like a broken record, but...

    Check for coolant leaks. Thats what I thought was wrong with mine, because it sounded to start up just fine, beeps and buzzes, HD's spinning, I just wouldn't get any video. I was just about to go on eBay and buy a new graphics card when I noticed some yellow fuzz underneath the processors.

    Panic ensued.
    Google'd.
    Apple repairs free of charge.
    Excitement.
    Called Apple.
    Repairs didn't fix it, or they couldn't get all the parts they needed.
    Got a free Mac Pro
     
  3. macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #3
    Its the graphics card or the driver for the card. Lots of times it just needs to be reseated.
     

Share This Page