Powermac G4 Power failure?

Discussion in 'PowerPC Macs' started by Reddmanz, Jan 30, 2011.

  1. macrumors regular

    Joined:
    Jul 23, 2010
    #1
    Hey guys,
    I used to use my G4 Powermac every day with no problems, then I bought my MBP and obviously it got sidelined :p

    It has been left in the same place as when I used to use it but when I tried to boot it up the other day,the light on the front came alive for a second and died again. I then noticed that the there was 'sparking' sound coming from the power supply area.

    I'd quite like this machine back up and running and I'm guessing the power supply has had it? Before I go and try and find one I just thought I'd check by here first to make sure I'm right as I cant think of what else it would be.

    Thanks
     
  2. macrumors 68000

    Joined:
    Feb 13, 2009
    Location:
    United Kingdom
    #2
    Sounds like a dead PSU - however I can make my G4s arc just by loosening the power cable - check its pushed in tight, if it is, get a replacement PSU, as thats likely the culprit.
     
  3. macrumors 68000

    Nameci

    Joined:
    Oct 29, 2010
    Location:
    The Philippines...
    #3
    I remember i have this issue before the first time I have rescued a PowerMac G4 400 from the dumpster. I just replaced the battery, reset PRAM and it worked fine.
     
  4. thread starter macrumors regular

    Joined:
    Jul 23, 2010
    #4
    I don't have the correct battery although I have ones which fit but are a bit more powerful. Im gunna try and pick up one which matches the original.
     

Share This Page