1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Powermac G4 QuickSilver and Powermac g4 agp

Discussion in 'PowerPC Macs' started by calb818, Jan 22, 2011.

  1. calb818, Jan 22, 2011
    Last edited: Jan 22, 2011

    macrumors newbie

    Hello to all who can help me.
    I have been upgrading two old G4 Powermac's, one is a Quicksilver running a 1.6ghz cpu upgrade with full 1.5gb ram, it presently has a 32 mb graphics card but I am trying to upgrade to a ati radeon 9500pro 128mb that is a pc card that I am trying to flash for the mac. This card will end up in the agp Powermac eventually, I am also trying to flash a nvidia 6800gt 256mb which will stay in the quick silver. The Powermac agp is running a 1.4ghz cpu upgrade and a full 2 gb ram, they are quite quick, I just want better graphics.

    I have tried a few times now using a VNC connection between the two machines over both a hub and by firewire, both work great and get me remotely onto the machine I need to work on.

    I have tried using graphiccelerator which when I run it up allows me to get the rom I have loaded on the desktop, although it is a 9500 rom from the maclite website when it appears in the rom directory of graphiccelerator it comes up as radeon 9800 pro mac edition, rom 113-a07525-130. I thought what the hell lets see what happens, if I then open the ati software and choose the option ati tools, then multi flasher it comes back with the following two results, first carbon error 61, secondly invalid flasher! make sure its not locked or on a locked volume!

    Can anyone explain this to me and try to make sense of it.
    Does anyone have a better way of trying to flash the rom on these two cards using two mac's, I have read so many threads about using a pc, unfortunately my pc's do not have agp slots, they are all pci e machines.
    Any help is greatly appreciated.:confused:
  2. macrumors 68000

    Mac graphics cards tend to have larger ROM files to add Mac Compatibility, so its probable that the ROM you have cannot fit on your ATI Radeon, so it cant be made Mac Compatible (I recommend purchasing a Mac Edition of the card). Also, if your PowerMac G4 is an AGP it has a 2x AGP slot so make sure the card you want to put in there is compatible.
  3. macrumors newbie

    I hear what you are saying and concur, I did try using a smaller modified rom, it came back with the same results??????????????:confused:
  4. macrumors 68040


    What OS you're running and what VNC server/client hou have? Update OS to highest version possible. I use Graphicaccelerator for years and had this issue only once.
  5. macrumors 68000

    Its highly likely that wont work - you tend to need the full ROM for it to be guaranteed to work. One thing to try is to get Apple Cards or Mac Compatible cards (ATI Radeon 9800 Pro Mac Edition seems to be the highest end card for AGP PowerMacs)
  6. macrumors 68040


    You're wrong. I've flashed cards with 64k (reduced) ROMs using Graphiccelerator many, many times. Don't tell me that I was lucky ;)
    Thomas Perrier wrote this tool to be compatible with many ROMs no matter what size they are. Full list could be found on his site.
    9500 ROM is modification of 9800 v130 ROM IIRC and it's fully compatible with Graphiccelerator.

    OP, can you post picture of the card? Or answer if it has BGA chips (square ones). Only those are flashable. Did you try to dump original ROM from 9500? It's a "must do" thing.
  7. macrumors 68000

    Oh your lucky alright. The reduced ROMs are more than likely not to work with many cards. - There I just did, whatre you going to do about it?
  8. macrumors 68040


    I'm gonna tell that you should get more experience with flashing cards to give advices to other people ;) :D
  9. macrumors 68000

    And I'm gonna tell you Ive flashed 100 maybe 200 cards, and had success with maybe 35% of them (for Macs at least, 100% of them work when re-flashed to PC spec pretty much), so maybe you should try and not actually tell other forum members what to do and what experience they do or dont have :rolleyes:
  10. macrumors 68040


    I'm crushed with your experience :p, sadly you didn't learn flashing basics if you've had only 35% success. But it's all ahead you, keep trying ;)

    OP, if you find this and other my posts off-topic, feel free to report them to the mods. It was my bad to argue with teenager, I'm sorry :)
  11. Dave H, Jan 23, 2011
    Last edited: Jan 23, 2011

    macrumors 6502

    Dave H

    What brand is the ROM chip on your card?
  12. macrumors newbie

    Hello there, my OS is 10.4.11 so it is the latest for tiger, I am using Chicken of the VNC as my VNC tool it seems to be working ok, lets me onto the remote machine great and lets me do anything on the system. The carbon copy 61 and the locked message does confuse me. I am sure I am using the graphiccellarator correctly I have followed the advice from other strings and the steps from the graphiccellerator read me files, very confused???:confused:
  13. macrumors 68040


    Did you try to dump PC ROM off the card using ATI Multi Dumper? Is it giving you the same error message? I assume you know about necessity of running Run Me First script before using ATI Multi Flasher (as stated in Readme file).
    Did you try in safe boot (I've never had to, BTW)?

    Problem is that I don't remember when exactly I've had this message and what caused it - it was in the far past and occured only once.

    Your VNC tools shouldn't be a problem, they work well with 10.4 (I use them too).
  14. calb818, Jan 24, 2011
    Last edited: Jan 24, 2011

    macrumors newbie

    I have another observation about this, on the notes it did say that using OS X 10.4 and above that the machine may have to be in safe mode, so I tried booting it in safe mode with my old graphic card in, I then tried to remote connect using VNC, no luck it will not connect so I have gone through network connections etc and set it all up, I can get onto the www in safe mode but alas I cannot remote connect, I even tried port 5900, 5500 and 220 no joy. I can however remote connect from the machine in safe mode to the machine I am using to do the work with, so it looks like something has changed on a port on the machine in safe mode. Has anyone got any ideas, has anyone remote connected using VNC while IN SAFE MODE???:confused:
  15. calb818, Jan 24, 2011
    Last edited: Jan 24, 2011

    macrumors newbie

    Thanks for the reply, yes I have done the RUN ME FIRST, and yes I get the same reply back if I run ATI Multi Dumper, so any ideas??? One thing I did forget to mention, I have taped up tabs 3 and 11 on this card, is it possible that on a 9500 pro they do not need to be? I have check the rom chip and it is numbered so M25P05V6 this is a 128kb rom according to the information on the maclite site.
  16. 666sheep, Jan 24, 2011
    Last edited: Jan 24, 2011

    macrumors 68040


    Code -61 is permissions error. Check all Graphiccelerator files permissions if you have read and write access on them. Which computer is host and which one is client? Maybe try to "swap" them.

    Edit: M25P05V6 seems to be 64K, 128K was M25P10V6. But, according to Thomas Perrier it could be also 128K :D

  17. macrumors newbie

    Well I will keep on trying, on the permissions side of life I have Read and Write, does the Group have to have access, the owner does and has R&W.
  18. macrumors 68040



Share This Page