PowerMac G5 Dual 2.7 fan problem - PLEASE HELP!!!

Discussion in 'Macintosh Computers' started by powermac_daddy, Nov 18, 2005.

  1. macrumors 6502

    powermac_daddy

    Joined:
    Feb 22, 2005
    Location:
    Philadelphia & Northern California
    #1
    I have a G5 Daul 2.7 with 2g of ram (OX 10.4.3). I do a lot of vectorworks 3D rendering ( architectural )on this puppy. I have noticed a problem lately: The fan stays on after i wake up the computer. I don't think they are the processors' fans, i think it might be the fan that with the speaker. I'm not 100% sure. Well, the fan would stay normal if i restart the computer. The fan problem only occur after i awake the computer from the sleep mode.

    Can someone help me? Any suggestions? Feel free to drop me a line on aim: mrdingliu
    Thank you very much for reading my post.
     
  2. macrumors 68030

    FFTT

    Joined:
    Apr 17, 2004
    Location:
    A Stoned Throw From Ground Zero
    #2
    The last 10.4.3 update has caused quite a few quirks including extra fan activity.

    Mine seems to ramp up every once in a while now too but only for a moment.

    Apple already has OS X 10.4.4 in the works and it should help with some of these issues.

    You might also want to check macfixit.com 10.4.3 threads about fan
    and sleep issues.

    If you have Vectorworks set up to run as a start-up item, then that might also be the cause of the fans running when you wake from sleep

    It's just reloading the application to get ready for work.
     
  3. macrumors 6502a

    Will Cheyney

    Joined:
    Jul 13, 2005
    Location:
    United Kingdom
    #3
    After updating to 10.4.3 I too suffered from excessive fan noise.
    Here's how I fixed it (I did a little research on this board and at www.macosxhits.com).

    1.
    Open the Energy Saver System Preferences panel, and click the Options tab. Click the Processor Performance pop-up menu, and set it to either Highest or Lowest -- anything other than Automatic. Close the panel, and you're done. Not wanting to give up any performance, I set mine to Highest.

    2.
    This will keep your G5 even quieter. It will also eliminate any annoying beeps or chirps that can he heard from within during certain processes.

    The solution to the chirping problem is to disable "CPU napping." From my understanding of it, this is a lower-power mode for the CPUs, invoked automatically by the G5's power management functions. The G5 wasn't designed to be a 'power conservator' so you may ask yourself what the pint in such functions is. You need to install CHUD, which is short for Computer Hardware Understanding Tools. If not already installed, you can get it straight from Apple, here: ftp://ftp.apple.com/developer/Tool_Chest/Testing_-_Debugging/Performance_tools/. Download the most recent version (which is 4.2.3 I believe). After installation, look in the Other section of System Preferences, and you'll see a new Processor panel (I think it's called Hardware in 10.3). Open that, and uncheck Allow Nap.

    Also note that if you restart, the nap setting is reset, so you'll need to re-open the prefs panel to fix it again. Alternatively, this older hint explained how to use a simple AppleScript to enable the nap setting at each restart. Change the =1 to =0 in the script, and you should have a "nap disabling" startup item (though I haven't tested this).


    Hope this helps!
     
  4. thread starter macrumors 6502

    powermac_daddy

    Joined:
    Feb 22, 2005
    Location:
    Philadelphia & Northern California
    #4
    i had that set up... i'm seeking other solutions.
    thank you very much for the help Will.
     

Share This Page