PowerShot A710 IS problems

Discussion in 'Digital Photography' started by Mr_Brightside_@, Mar 3, 2007.

  1. Mr_Brightside_@ macrumors 68000


    Sep 23, 2005
    The 6ix
    Hey my PowerShot A710 IS has an issue- basically, it won't turn on. I've tried different batteries- not all of them, and that has done nothing. ALso, there is anothre small slot in the abbtery holder that contains a small circular battery, could that be the problem? Any help would be great.
  2. Grimace macrumors 68040


    Feb 17, 2003
    with Hamburglar.
    really tough to say without seeing what's going on. I'd make sure the battery is charged all the way -- if not, you might contact a Canon authorized repair center.
  3. Lovesong macrumors 65816


    Sep 15, 2006
    Stuck beween a rock and a hard place
    The small battery is for the date-time memory- basically there so that you don't have to re-enter your date everytime you change the batteries. Read your manual- is there a way to perform a hard restart? Also, what happened to the camera? Did you get it wet? Dropped it? Left it in a hot car? It would be good to know how this problem came about, so that the issue could be narrowed.
  4. 12991 macrumors member

    Feb 3, 2007
    Did you put the batteries in the right way? I have the same camera, and the first time I put the batteries in, i did them the wrong way (I was in a dark room, so I didnt no any better)

    Got the cam yesterday, its great! But im returning it tomorrow because its gotten me so into photography that im getting the powershot s3, the d40, or the rebel xt tomorrow. I hope you figure out your problem

Share This Page