Preference plist files not saving updates

Discussion in 'OS X' started by mkaake, Jun 14, 2009.

  1. macrumors 65816

    Joined:
    Apr 10, 2003
    Location:
    mi
    #1
    This is an odd one, and I haven't been able to find similar situations (or solutions, for that matter). I've been experiencing some oddness while using my mac, for a while now - I'll save the long story, but the short version is this - for some reason, programs seem unable to save any changes to preference files. Even if I trash the original .plist files and create a new one - after the original file is created, no new changes are saved. Perusing my preference folder, no .plist file has had any changes saved for some time (Feb 24). I haven't been using this machine too much lately (mostly my wife uses it), so I hadn't noticed it earlier, but now its driving me crazy (especially since Safari 4 went out of beta - I can't save any preferences, so I now have an apple start page, and get the 'top sites' every time I open a new window or tab...)

    Anyhew, if anyone has any thoughts, I'd love to hear them - I've tried reparing permissions, repairing the disk, forcing cron jobs, combo updating vs. the auto update (to 10.5.7), but the plist files still refuse to update.

    Not sure where to go from here, and I really don't want to entertain the thought of re-installing over this issue... I'd like to find out why it's happening and fix it.
     
  2. thread starter macrumors 65816

    Joined:
    Apr 10, 2003
    Location:
    mi
    #2
    Bugger. I was hoping I had just forgotten to click on the 'instant email notification' button. :eek:
     
  3. macrumors newbie

    Joined:
    Jun 15, 2011
    #3
    Same problem with permission files.
    Did you fixed that somehow or you created a new acount?
    Coz in the new test account i created everything seems to work fine.
    Any helpful info will be much appreciated.
    Thank you in advance
     
  4. thread starter macrumors 65816

    Joined:
    Apr 10, 2003
    Location:
    mi
    #4
    No, never found resolution. Only options were to use a different account, or re-install. Sorry -
     
  5. macrumors newbie

    Joined:
    Jun 15, 2011
    #5
    Thanx for your reply mkaake.
    If i won't find a solution soon, a new user account maybe my best option.
     

Share This Page