Preview 3.0.9 won't work at all anymore, help?

Discussion in 'PowerPC Macs' started by NeoNirvana, Jun 11, 2010.

  1. macrumors newbie

    Joined:
    Jun 11, 2010
    #1
    So yeah, Preview just randomly stopped working, when I open a file (try to anyway) it shuts down as soon as the app name comes up.

    I already searched the forums and deleted the Preference .plist files as suggested which apparently worked for that person, but not for me. I can't find anything anywhere on this, not even a .dmg for Preview, what can I do?
     
  2. macrumors newbie

    Joined:
    Feb 10, 2010
    #2
    first, try repairing permissions in disc utility.

    if that fails, uninstall preview by trashing it and do an archive and install. http://support.apple.com/kb/ht1710

    if you don't already have a back up, make one.

    though archives and installs usually are problem free, things can go wrong. data can be lost.
     
  3. thread starter macrumors newbie

    Joined:
    Jun 11, 2010
    #3
    Do I completely reinstall the OS after trashing? Is there a way to do it without the installation disk?

    The permissions restoration didn't work. :(

    Is there a .dmg for Preview somewhere? Would that even work?

    Sorry about all the questions, a lot of this stuff is foreign to me. *_*
     
  4. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #4
    You are running 10.4, correct? Do you have all OS updates installed? If not, you should install them and see if it will help.
    Reinstalling whole system should not necessary. Download your OS disk image, mount it, then use http://www.versiontracker.com/dyn/moreinfo/macosx/12743 to extract Preview.pkg (it should name like this). This is needed install file.
     
  5. thread starter macrumors newbie

    Joined:
    Jun 11, 2010
  6. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #6
    Google it. This all I can say, to do not break forum rules.
     
  7. thread starter macrumors newbie

    Joined:
    Jun 11, 2010
    #7
    Exactly what am I looking for? I search OS X Tiger disk image and it's just a bunch of random crap that comes up. Sorry for my ineptitude but I really am lost on this. :/

    Would it work if someone shared a Preview.pkg with me?
     
  8. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #8
    Preview should be in Essentials.pkg. There is search module in Pacifist (upper right). Type "preview" there and it will find "Preview.app" file located in Essentials.pkg (checked it before moment on my PB 10.4 install disc).
    Trash your existing Preview.app (or backup to external and trash) and all related .plist files - you can use AppCleaner or something similar to do it automatically. Then extract Preview.app with Pacifist and place in Applications folder. Reboot and check if it works now.
    Edit:
    if it will work, next step will be software update, to update Preview to highest version available for your OS.
     
  9. thread starter macrumors newbie

    Joined:
    Jun 11, 2010
    #9
    Ok I've found it in the Essentials .pkg, but it won't let me extract it. I tried authorizing it but it still won't give me the option. :confused:
     
  10. macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #10
  11. thread starter macrumors newbie

    Joined:
    Jun 11, 2010

Share This Page